I am trying to get sharp shadows with static lights but they always come out blocky even with fixing lightmaps to a higher resolution what is the fix for this? I also am using default unreal cubes as a floor so the lightmap UV must be fine

As my questions states, there is just a big issue with static lights not giving me sharp shadows even with higher lightmap resolution and using default unreal cubes as floor and shadow casting geo. It makes no sense I see everyone saying just use stationary but what if the game is doesn’t require that or want static shadows for performance? Help would be appreciated.


If you’re using BSPs then lower lightmap resolutions will give you better results!!
If not… How high is the floor’s lightmap resolution? Can you show a screenshot of your shadows and settings?

Hello, Makigirl yeah there is the image of it. The floor lightmap is in the red just a basic plane from the basic meshes tab. Also, the two cubes are in the green for lightmap densities around 128. That is all I have in the scene and the world settings are the default for the lightmass.

Well 128 lightmap resolution is very low for a mesh this big if you want perfect lighting information!! The blocks you see in the shadows are basically your max “unit” you set for lighting!! /if you check your lightmap density view, you’ll see the blocks will line up with the lightmap grid!/
Try something like 1024 or 2048!!

oh no the plane has 2048/ 1024 lightmap res. It was in the red while looking at the lightmap density viewer set to above what is needed. I still get those jagged shadows that confuse me. I am curious how normal static shadows are supposed to look like. Everyone just says use stationery but I require static shadows to save on performance.

You don’t have to use stationary lights if you don’t need them in your scene, that’s no good advice from others!! Static lights should look great!!
Could you show your lightmap density view please?
Are you sure you don’t use BSP meshes?? Those need lower lightmap resulutions to get better results!!

That’s the mesh and the lightmap density view! What does BSP mesh stand for? And I know its for blocking. But I have some other planes I am using in my project with the same exact lightmap UV and get chunky shadows. :…)) I just want to use static shadows and get them to look sharp by adjusting lightmap resolutions. I appreciate the help too.
alt text

i added the two images now

Hmmm… Very strange!! Was trying to replicate your scene and this is my result on a preview build:

The plane has a 1024 lightmap resolution, the cubes 128…

I get similar results with 256 res lightmap on the floor!
After you’ve set the higher resolution lightmap: have you re-built your lights? /your screenshot says it’s before the light build…

mhhh the engine version was tweaked so its now a custom one think maybe a setting was tweaked which changes the quality of the shadows its strange. I was thinking the same just weaked them should be fine. Do you know of any setting that should change that? or world settings? this is strange so I am not going crazy. I know I should be able to have solid static shadows. I dont’ have a post process could that be it?

pfff… low memory maybe… No other guesses really… I just put the post process volume to turn off the lens flare I was getting…

i gotcha thanks a ton Maki! I just wanted a sanity check to make sure I wasn’t going crazy maybe a setting was edited to clamp the shadow quality from going higher.