Download

How would I stop my characters hair from glowing in point lights?

I can’t seem to figure out a way to stop the characters hair from glowing whenever in the presence of point lights, in spotlights however it looks perfect. I’ve attached an image demonstrating. The left is under a point light, the right is under a spotlight.

Thanks.

Is the point light shadow casting?

Yes, it looks great if I turn the shadow casting off though. I’ve largely managed to fix it through changes to specific parameters such as Shadow Bias. I don’t know enough about UE4’s renderer to fix it properly, but I think it’s something to do with the way hair is lit volumetrically. I can see the steps in the shadows as I approach the light with the character until it renders correctly. I’ll just have to carefully adjust each light independently depending on the scene.

What material are you using?

All of them, I’ve made multiple hair materials, pulled some of epics, and even tried buying a character from the marketplace and using that. If the shading model is set to Hair then it looks like that near shadow casting point lights.

I don’t think there’s anything wrong with it in the sense that it’s unexpected behavior for the hair shader, I’m just looking for a work around or technique to stop it.

Ok, I was having the same issue just now with eyelashes, but changing the blend mode to translucent fixed it.
Surely that may not be ideal in terms of rendering costs for a full hair-do… However, this may actually be a rendering bug rather then a desired feature?

Translucency doesn’t support many other rendering features and, in my experience, causes other weird rendering issues. I’m yet to find a solution to this though so… bump?

It used to be in 4.23 that it stopped happening if shadows were disabled on a light, but that is no longer the case. Anybody have any ideas?

OK, this is ridiculous, my solution to the problem was to stop casting shadows on lights that didn’t need them, which also solved an issue of performance as our target platforms are primarily consoles. But since the update to 4.24 this happens with non shadow casting dynamic lights. I have done far to much work before noticing to revert back and players will not accept this.

What has changed between versions for this to suddenly become such a problem?

Can somebody from Epic please offer some help here?

EDIT: ALL hair does this, including Epics own demo scenes and Paragon characters.

Bumping this one, I have similar problem using the hair shader…I’ve got lots of point light with no Shadow in my scene :frowning: . My Solution for now is to disable all the roughness in the hair shader… I know its ugly…but rather than glowing in the dark…The Hair shader somewhat only play nice with spotlight…

notes: My base hair shader is a modified hair material that comes from the paragon…

Hope there is a solution from Epic Team

I had to resort to just ditching the hair shader altogether and starting from scratch using the subsurface shading model and a Fresnel effect around it.

It doesn’t look as nice of course but it’s better than a glowing head.

Did you check the Make Human sample project?

I Specifically tested pointlights before the last update and didn’t see this happening on the default mesh.
Then again I had also messed with the shader, I’d have to check it again.

The setting causing this is the sub surface scattering.

Are you using a ready made material from one of the available project files? Had the same problem but went away when we use the material from a Paragon example.Same as the eye material as well

I think DigitalHuman sample project does not have the same issue.


At least, from what I’m looking at, it’s not the whole thing that lights up like a Christmas light.

here’s the rest of the sharers compiled. This is from the completely black map - just the pointlight added.

Hey!
Have you found something? I think current hair and groom got this problem too. For me In new levels every hair is looking fine but in some levels with full of geo and lights, they’re glowing, when rendering out with exr sequence, they’re just black curves nothing more.

Hey,

That’s because your pointlight is casting shadows. It’s only an issue with non shadow casting lights.

Thanks,

Nathan

The new engine version with the new exposure settings and sky atmosphere has made this - yet again - an issue.
Granted, I imported the character, so I may be missing some basic settings.

The issue is actually the sub surface scattering. Illustraded here.


In this shot, the sun is directly behind the head. Thus, the hair we see as lit by the ear should be completely dark.

Naturally, this could also now be due to the fact that the changes I had made to the material to avoid the shine by sampling the world normals are now no longer needed… hard to tell without a 5 hour review :stuck_out_tongue:

update. Recompute tangent option on the hair material helps a lot with this.
for whatever reason porting the project to .25 had disabled the option and unchecked it for the material on the mesh.

There is that option “Recompute tangent option”?

I had this same issue. Minimized when I set Hair Blend Mode to Opaque and Shading Model to Default Lit.

Here I’m using the Mixamo character Adam (with a random color generation tool on the track suit…)

Hair is not Opaque or Default lit.
The reson behind a different shader is that it shades differently in order to look natural.

If what you are doing is something more than just a basic game and you actually need stuff to render in PBR appropriately, all your settings are doing is to render hair as any surface instead of hair.