How to set up the landscape textures properly?

Hi Guys,

For the last couple of days I’ve been struggling with properly texturing my landscape, and I’m at the point where I just want to give up and go deal with something else.

That’s how my material looks like:


  1. Unlinked normal maps to check if this is going to be of any help

  2. This is how are the materials look like in the layer blend


Basically what happens is these textures don’t get painted correctly onto my landscape (15x15, decided to go with a small one to experiment with the materials). I manage to get a dab or two, then the shaders start compiling (every time i swap the texture I’m painting with pretty much), which is terribly time consuming as it’s taking about 10 minutes every time.

What I did step by step preparing the textures for painting the landscape:

  1. Create a new material, use layer blend to add .png textures to it
  2. All textures connected to layer blend are set as LB Weight Blend
  3. Only the first one has preview weight set to 1.0, the remaining ones are at 0.0
  4. Constant “0” connected to metallic
  5. Constant “0.5” connected to roughness
  6. I have followed the same process with normal maps as for the base textures
  7. save, compile, close the editor

This is how the material looks within the landscape settings/tools


  1. Added “LayerInfo” for each texture before I started trying to paint with them
  2. Tried to “cover” the entire landscape with a huge brush, and going through every single material to get the shaders compiled once

What am I doing wrong? I’ve been stuck with this for quite a while now, and I just can’t be creative anymore to try and think of another solution to this problem.

ps. many times after I’ve applied this material the editor would just crash, so I unlinked the Normal nodes.

oh come on.

I’ve seen this tutorial too many times already. Basically I have two issues right now:

  1. shaders keep compiling all the time when I’m painting the texture on the landscape, and I’ve been trying to battle this for days.
  2. When I started using height maps (as one things that I needed to try to fix the issue #1), my terrain started being covered with black spots.

Tbh I’m pretty sick of how UE handles this, never had any issues like this in other editors/engines, it should be a simple straight forward process.

It’s week-end, that’s why it could take longer till you get an answer. :wink: What exactly is your problem? Take a look at this tutorial: ?v=tsXVP0fykBM

Hello Roball,

I do know of a few ways to get rid of your black spots that are appearing on your landscape. The shaders need to compile if you are painting on a section of the landscape that has not received prior information of whatever layer you have selected. Therefore; if you have multiple textures and are trying to apply them all to one section of your landscape, the shaders need to compile to calculate how to blend with the other textures. This is a normal and expected outcome whenever painting on a landscape. As soon as you have applied some any information of that layer to the component section of your landscape, you should not be experiencing the constant re-compiles as you described.

I helped another user with a similar issue and showed him how I set up my Landscape Material, and how I use ‘LandscapeCoords’ per each texture ‘UV’ to get custom scaling for the individual textures and their respective Normals.
Try and follow the steps and use the images as reference for your own landscape set up.

Black on Landscape Texture

I hope this gives you some clarity on the issue and helps you find a resolution. If you are still having problems, let me know and I can assist you further.


Hi Andrew,

First of all thanks for the reply. The setup you’re using for your texture is very similar to the one that I am using. I have seen the post that you’ve linked when I was googling through the answers page to find help, however I have tried it anyway.

It might be that I don’t understand the differences in blending settings, I think I messed up at this stage and it’s hard for me to tell what’s up.

This is my material at the moment -


Layer blending is set up as follows:



I noticed in your screenshots that your textures are set to “No weight-blend”, so I did the same with mine.

Right now I can’t paint the textures on the terrain at all, I guess that’s because I chose the no weight-blend option for each one of the textures in my landscape material.

I don’t know, it seems like I’m missing something really small, and I feel rather stupid that I’m stuck with such a basic issue for this long…

Hello Roball,

Firstly, don’t feel stupid because these kinds of things can happen. The smallest changes can make the biggest difference. The one thing I see different from my material set-up and yours is the “LandscapeCoords” node. I have one for each texture object in my material editor, instead of a single large one. Duplicate the one you have and connect them to their own respective layers. Also delete your Metallic Constant as this is not really needed.

Also within your material properties, under ‘Usage’, check the ‘Used with Landscape’ and the ‘Used with Static Lighting.’ Let me know if this resolves your issue.

Material Set Up


Hi Andrew, again - thanks for the reply.

It looks like it might be working properly now. At first I wasnt’ able to paint anything over the “main” texture, however after removing them all, then painting them all over the map again it looks like the shader compiling FINALLY stopped.
I’ll have to experiment with it a bit before I can say it’s fixed, it took me so much time to have it fixed I really can’t believe that this might be the solution…

By the way - what are the differences in “No weight-blend” and “weighted blend” when creating new layers? There’s so many blending options here I really don’t quite understand them.

You are welcome.

I could explain it in my own terms, but the documentation we have provides the most accurate definition. Also this documentation addresses the issue you had, and one way to work around the black spots you were having. It suggests changing one of your Layer Blends to and AlphaBlend.

This documentation should explain the questions you have. Hope this helps!



I’ve seen that doc already, but I’m going to give it another read now when I’m not frustrated with the issues I had before.

Thank you again for your great help, I can finally move on to other things. :wink: