How to remove small gray corners on 2D sprites in game?

I am new to 2D in unreal, but after watching a few tutorials, decided to give it a go.
I open up 2D side scroller template, import some simple png image, apply paper2d settings to it, and turn it into a sprite. So far so good - the sprite looks exactly as an original image. I drag the sprite into the game viewport - also good, no changes in appearance.
When I press play, however, I notice some tiny gray corners on my sprite, where different colors merge. Those borders weren’t visible in the original image, nor in the sprite, nor in the viewport - they appear only when the game is played. Regardless of the size of the sprite, or its scale, these corners are always 1pixel wide. Barely noticeable for big sprites, but since I want to make a retro styled game using 16x16 sprites, it really bothers me.
I played around with settings, and it seems that this problem occurs only for orthographic mode of the camera. I need to use that mode, unfortunately. I also made sure that the “ortho width” is equal to window width, just in case. Nothing helps, however.

Here’s an image of a sprite in viewport - all edges are seen clearly. (blue is the background, while everything else is one single sprite)


And here is a snip from the actual game, magnified to X3 as it’s hard to see otherwise.


Can anyone help me figure out the source of the problem, and possibly how to solve it?
Thanks in advance.

Which settings you use for texture? 2D pixels (unfiltered)?

I can see that it use some compressing for power of 2 square textures even if NoMipMaps set.

Well, this not reproduced for not power of 2 textures.

Texture group is set to 2D Pixels (unfiltered). Tried all options for power of 2 mode, but there is no difference.

Setting Anti-Aliasing method to None in Project Settings fixed the problem! Yay!