Download

How to overlap textures in material?

How would I get these two materials to overlap? The center circle of the crosshairs one is actually transparent in the file but it doesn’t show it in editor. I’ve tried add, blend, overlap, others but nothing work quite right. It often will come out with the sides of the inner circle visible but not the background;

Set your texture from opaque to masked, and then plug it into the opacity masked node. Most of those blends are photoshop blending emulators that I know of.

Like this? But now it’s invisible.

Do I have the textures wrong in the engine?

If you just want a black crosshair you could maybe lerp between colored view texture and pure black using an alpha or black&white of the crosshair?

I’ve tried lerping too and that didn’t work. I’ve tried a lot and nothing works concrete.

Did you fix the error in your picture above? Looks like you have to swap read mode to something else depending on that fileformat and file read+compression settings.

I fixed the error it still didn’t work. Like I said last when I tried to do the overlay mask it became invisible.

There is a lot of info in a texture… With just your crosshair texture plug top node into base color, and bottom node into opacity mask. If that doesnt work take a look at your texture settings, and turn off mips, and change to srgb. It may have imported as a normal map.

Like this?