How to input 16bit png (or other 16bit-tex) in the engine?

hi Guys.

I am studying the content in this video:
[Part 3. Thatched Roofs: Medieval Game Environment in UE4 - YouTube][1]

At 6:35 time. it uses a displacement map to create the high mesh by Modeling tools. The mesh looks so smooth. I want to do the same thing.

on video:


So, I input the displacement map into the engine and use it. I just got this:

I find the problem(Maybe): the texture format is G8. so it can’t provide enough depth.

My source file is the 16bit-png. I try to change the compression setting but still can’t get the format to turn to G16.

So how to input 16bit-png into the engine?


I know this is an old-ish post, but in case you or anyone else is still looking for an answer:
In the following example I am using a heightmap of a terrain, but that should not matter all that much.

This issue might be related to the UE version you are using.

When I try to import this 16 bit PNG:

I get the following results:

[UE 4.26]
Drag and drop the image into the Content Browser and double click it to open the Texture Editor.

Under “Compression Settings” you can select “Grayscale”.
When you now click “Save” this should result in a “G16” image, however in UE 4.26 the result is:


And applied to a landscape it looks like this:

And I have no idea how to fix this.

[UE 4.27 / UE 5.0]
However when using a newer version of UE, without changing the work flow:

The result is the following:


And applied to a landscape the result is this:

This is not really an answer to you question, but I hope it helps.

If I find a way to “fix” the UE 4.26 import I will update this post.