How to improve lightmass shadow quality?

Hi guys & gals!

Ive been playing around with lightmass today & must say Im very impressed so far. What I can`t seem to figure out though, is how to improve shadow quality in the bakes. I tried boosting both the “Shadow Exponent” of the light source and the lightmap resolution, but I notice little or no visible difference.

Any lightmass masters out there that can help out?

All the best,


Select the floor, if it a bps brush go to the details panel and decrease the light map resolution to like 2. Lower is better. If it’s a static mesh, select it and bring up the editor for the mesh, increase resolution to higher value.

Hi there! I tried increasing the lightmap resolution, but the shadow still ends up “blocky”. I’ll do some more testing tonight & see what happens :slight_smile:

Thanks for the reply!


What is the box? Static mesh or BSP brush?

even if you set the lightmap to 2048 it’s not going to get much better. Two options at this point. One is to manually pack your UV where the floor surface is bigger. Two would be to just throw down a BSP brush and set the lightmap for that surface to 1.

If you send me your FBX of that box. I’ll repack it for you.

It’s a static mesh with a proper, secondary uv-channel for the lightmap :slight_smile:

I usually pack my lightmap uv channel manually, so this model should have a clean and optimized uv-set for the lightmaps. I`ll post a .zip of the scene here tomorrow though, so you can have a look!

Thanks again!


You can send an email Christopher at innovative sales tools dot com. The auto correct won’t let emails to be placed as a link

I had this problem too, building lights in ‘production’ mode has the best quality but still creates artifacts, especially on round surfaces.

Here is the same, well what i guessed was the same. Is this what you were looking for?

Yeah! That looks great man! Did you just increase the lightmap resolution until it looked good or did you come up with some other trick?

Thanks for the reply btw!


The thing about games is that the best looking thing is also the biggest lie. Its always a balancing act to time and effort. If you put your image on a tile floor you wouldn’t be able to tell that it was a little jaggy. I packed the UV to make sure the floor and inside walls have the most information.

For the most part this is all about the UV for lightmap. The larger your object, or more complex, the higher the resolution you may need to set your Lightmap Resolution to. The default lightmap resolution for each static mesh is 32. If the object is overly large, and additionally has lots of information packed into it’s uv coordinates for the lightmap, then you need to increase this. To test the best resolution try bringing your object into a default scene, with nothing in it, to tweak your shadow settings instead of testing in your game. This way you can quickly build lighting and test different resolution without building out an entire game over and over.

The problem with really large objects is that your resolution may have to be significantly increased to get clean shadows. Double them from 32 to 64, then 128, then 256, then 512. If you keep having problems and keep increasing your resolution to the detriment of game play it may be time to break your object up. Many people still have not learned the lesson of keeping objects modular, i.e. smaller bits to build something.

So instead of having an entire house, the house may have to be broken up considerably, and then brought into the software to maximize the shadow details. Ideally, if you can build modular parts to build the same house, then you can build the house, or even many houses, and keep the resolution of lightmap fairly low.

Things to be aware of is when you trade off convenience of having one object, for loss of speed in the engine when building lightmaps or even loading them later.

How to creat the first darker shadow of your image,the shadow under the stone?

That looks like screenspace ambient occlusion. You can use a Post Process Volume to tweak that.