how to have opacity fade on alpha?

how do i give something an opacity fade from the alpha channel?.. a soft fade. So far all of my attempts make it seem like they dont obey lighting at all… either super bright or super dark on the entire material.

Hi there.

To make a materials opacity dependent of the alpha channel you have to do 2 things:

  • Changing the materials blend mode to translucent.
    This can be done in the details panel of the material under Details > Material > Blend Mode > Translucent.


  • Connecting the alpha channel to the opacity input of the material.

The second image is taken from the ue4 documentation about parameter:

You misunderstand… that doesnt work. Yes i get teh alpha channel… but the material itself looks like crap in any lighting situation… for example im using it on my characters hair. And it makes the hair overly bright vs the rest of teh body in 1 environment… or overly dark in another differently lit environment… Plus it does not receive any realtime shadows…