How to handle raytraced shadows?

Hi guys, I really like that there are raytraced shadows. However, I have noticed a few things, and is wondering what can be done to alleviate the problem.

I activated the raytraced dustance field shadows, but (like noted elsewhere) there are no shadows on characters, which is kind of a problem. How do I set things up so that moving characters also get their shadows?

I have also found that the raytraced distance field shadows create some animated dark areas (that sometimes turn to small ‘squares’ even in plain walls in direct light. Just because the area happens to contain a dark spot. The problem with these animated dark areas is that they leak, from under wall sections etc… I lifted a block up to help illustrate what I talk about. But my question is, can I control these somehow? Make them smaller, make them static (which is what I really prefer) etc…?

Those dark blothces are caused by distance field ambient occlusion. You can disable it by turning off Cast Shadows in your Skylight.

For ray shadows for skeletal meshes, enable Inset Shadows in their properties. They wont cast soft shadows though, just normal detailed shadows. Any other shadowing problems you have with ray traced shadows on static meshes is probably caused by your meshes so you may need to increase Distance Field Resolution Scale for those meshes.

Thanks a lot Jacky, that did the trick :slight_smile: Much appreciated.

I tried enabling the inset shadows on the character from 3rd person shooter template but still can’t see any shadows (other meshes do cast ray traced shadows). Any idea what could be the reason?

Seems like they only work for directional lights :frowning:
I’m having the same problem.