How to fix these artifacts after importing from Blender

Hello! I created a mesh in Blender, created two UV map (one for the mesh, and another for lightmap) and created textures and a material for this mesh. The problem is that when I import my mesh into UE4, I got horrible artifacts on my mesh, like this:


How can I fix this?

I removed the normal map, and I still have an artifact problem, but not the same than before:

It seems like a texture problem. If you are using a normal map for that material make sure it is set to Normal Map instead of Default.

Ok, it is a smoothing group issue then. You’ll have to get back to Blender and adjust the smoothing groups.

I came into fbx export options and put them like this, but still have the same issue. How can I adjust smoothing groups?

EDIT: Find a way: Use “Edge split” modifier!

Use Edge Split on your object in Blender, before exporting :slight_smile: