How to Fix Light Leaks? [Lumen][UE5]

Hey guys, fairly new to the scene and first time asking a question. I am having an issue with point lights leaking light above and under my walls and I can’t seem to fix the issue. I’d really like to use Lumen for my game, if possible. Here’s some information:

  • I’m currently using UE5 and Lumen for my lighting.
  • I have the walls, ceiling, and floor (which was generated using the landscape tool) all completely flush, not overlapping.
  • My walls are 20cm thick.
  • Using post processing (infinite unbound) and my auto exposure is set to manual.
  • Lights used are Point Lights

Whatever additional info I need to provide, please let me know and I will provide it. Thank you so much in advance for the assistance!

Here’s what the scene looks like unlit (just as a reference).

Post a picture of the Lumen debug views

Sorry, I tried to find anything labeled lumen debug view, but was unsuccessful. Are you by chance referring to the lumen visualization mode?

These


lumen - overview


lumen - lumen scene


lumen - reflection view


lumen - surface cache

Seems to be leaking from the specular highlights from lights on the other side of the room. Might be able to fix this by simply setting their specular intensity to 0 but I’m not sure why this is happening. Maybe they’re unshadowed?

1 Like

Dropped specular scale to 0 and this definitely improved things, but still seeing light leakage. Here is the shadow settings for the light BP.


New lighting

Interestingly, I hopped in the game and when going from a lit location to the unlit location, my lighting changed and it actually leaked more than when I was viewing it in the editor or when I’d do “play from here” in the dark area.

Found the fix! After turning the “specular scale” to 0 and then the “shadow slope bias” to 0, my light leaks went away.

Thanks for your assistance @Arkiras !

1 Like