How To Fix Jagged Shadows?

Problem: The point-of-origin on shadows produces a sharp, jagged edge.


Detailed Explanation: I have tried to figure this out on my own, but days of searching and experimenting has yielded me zero results. See the sharp edges and triangles? That’s my problem. When the landscape casts a shadow, the point of origin is sharp and conforms to the brush wireframe. The end of the shadow is completely fine. Its nice, smooth, and blurred a tad. The jagged issue is littered all over my landscapes. I have remade this project several times. I’ve used a sculpted landscape in UE, as well as a generated heightmap from an external tool. I’ve tried adjusting everything under my Directional Light. I’ve tried using larger and more detailed Landscapes. I cannot for the life of me figure out how to fix this and it’s driving me up a wall. I’ve tried searching this answerhub, Google, the Discord, and while I’ve seen other people talking about this issue, I haven’t found a single solution. Note that I am using Ray Tracing but I’ve noticed this issue even if I disable the ray tracing feature, it’s just far less noticeable. My directional light (the sun) is set to movable. Does anyone have any ideas?

Is this, per chance, static lighting? Have you tried increasing the landscape light map res?

Ok, sorry, no idea then… :-/

This is a movable light, a “sun”. I’ve attached a screenshot of my World Outliner. Ignore the fact it says Landscape2, I’ve been deleting and remaking my landscape thinking that was the problem. Because this Directional Light is movable, I don’t believe I can set a light map. I think that’s just for statics? Someone suggested to me that I try 4.25 instead of 4.26, so I am actively installing that for a test.


Hey no problem. Thank you for stopping in and seeing if you could help, I appreciate it. :slight_smile:

Any news ?

I have the same issue, I’m using only dynamic movable lights (sun/moon).

This is most likely a commonly known artifact called the “shadow terminator” and it’s caused by differences between the true geometry and its smoothed normals. Increasing mesh detail will reduce the discrepancy and can often resolve the issue but isn’t always feasible. Reducing the sharpness of the geometry will have the same effect.
There are other more sophisticated solutions, but now that you know the problem it should be easier to find the method that suits you.

1 Like