How to choose graphics adaptor on startup

I’m running 2 instances of UE4 in standalone mode ( a networked game). I’d like to get each one to use a different graphics card (I have 2xnVidia 980 cards) - I thought UE did this itself but it’s not the case (I can see my 2nd card is doing nothing)

I’ve seen the line r.GraphicsAdapter=1 which i’ve tried adding to ConsoleVariables.ini in the engine folder but it seems to do nothing.



Actually - and i’m in 4.8.2 - When I add r.GraphicsAdapter=1 it says DirectX11 feature level 10.0 is required to run the engine.

That command is to be run through the console I beleive in game (the tilde ~) key. You can also run the blueprint node “RunConsoleCommand”

After some searching I find tihs, you may need to use Ramas victory extra BP nodes plugin and use the custom ini files to do selection at runtime.

How to override the adapter choice /
workaround the wrong decision For most
low level features in Unreal Engine we
use console variables to give user
control. For this feature the console
variable is called
“r.GraphicsAdapter”. You can type the
console variable name into the
OutputLog or in the game console to
get it’s current value and the help
using “r.GraphicsAdapter ?”. This is
the console variable help: User
request to pick a specific graphics
adapter (e.g. when using a integrated
graphics card with a descrete one) At
the moment this only works on Direct3D
-2: Take the first one that fulfills the criteria
-1: Favour non integrated because there are usually faster (default) 0:
Adpater #0 1: Adpater #1, …

You cannot change this setting at
runtime like most other console
variables but you can add a line to
the file consolevariables.ini:
r.GraphicsAdapter = -2 Note that to
set a console variable there you have
to add a “=”. Don’t add any characters
in front of it. The “;” you might see
there is to comment the line so that
is has no effect. You can check if
your change had effect looking at the
log again. You can type the console
variable name into the OutputLog or in
the game console to get its current

You dont happen to be running alaptop do you? Either way check your power settings and make sure its on stock high-performance.

Alot of the times the dx11 needed error requires you to A)update your video card drivers (both of time in these case) and make sure you download the latest directX (directX 12)

Hope this helps
Don’t forget to accept an answer that best clears your question up or answers it so when the community finds your question in the future via search/google they know exactly what you did to fix it/get it going.