How to avoid progressive light loading?

it happens with:

  • Sky Light set to Dynamic, even more when set to Static and Built .
  • emissive materials .

this looks like some global HDR-kind thing, but i can’t figure out how to disable it for certain objects . i checked the material details, level and project settings, still didn’t find anything helpful .

anyone please help .

UE 4.27

You can disable the exposure on the project → Rendering settings or via a post process volume. This should resolve this for you.

1 Like

Realistically this can only be done for unlit materials.

You could use a post process material with the stencil buffer to isolate the objects you want to exclude from exposure but you’re probably better off trying to find a different way to do what you want.

1 Like

this is exactly what i want .

but when im trying to make an unlit material, the only output pin available is Emissive Color . the object starts emitting light onto other objects, and i need to avoid that . making material unlit also disables the Material Domain setting . how would it be possible to make it not emit light ?

Divide the emissive by the EyeAdaptation node:


This will keep the intensity consistent at any* exposure

*Will break at extreme exposure values

1 Like