How do you mask out roughness on a mesh?

I am having problems in the roughness area. I was following along with an old professor online. When I tried to repeat what he was doing, I didn’t get the same result. When I plug in my black and white texture into the roughness input, the mesh remains shinny. I tried playing with the values and nothing, only being shinny and rough all over the mesh.

Here are some images and a video link to help better assist. The video link is the video I was following step by step. 1:52 is where he goes into the editor.

Also I tried using three different versions of unreal, all using fresh project files. 4.2.![alt text][1]1, 4.1, 4.5![alt text][2]

Here is my hardware.
i7-2600 @3.8
RAM 16
Radeon 6970


You need understand how Roughness work. 0 - is clear reflection, 1- is maximum blurred. In your example need invert your Roughness texture and make texture more contrasted.

Not to sound ungrateful, I do understand how roughness works to the extent of doing easy material none complex. but if you see the video of what I am talking about my setup is the same as his and I am not getting the same result. Something is not right with my unreal.

Just to prove to you, I am setting up the same thing as in your png, not getting the same result. Here is are some screens.

Besides being able to use a Vector1 for your Spec and Metal inputs (instead of a vector 3) your roughness has various shades of gray.

The closer to white, the more reflective your surface will be, this is enhanced by the specular value you put in.
Read up on: Physically Based Materials in Unreal Engine | Unreal Engine Documentation and play with the sliders.


Your texture roughness is too dark. Look carefully your lesson.

Look to this picture below.

I use texture with many dark pixels and this look very glossy.

I corrected texture in shader, but you can do this in photoshop. I just offset pixel data, and remove black and dark pixels.

Question, I want the darks to be completely rough and the lighter areas to be shinny ( just for testing purposes only) in theory shouldn’t that work?

Thanks, that helped. Can you show me your graph so i can better understand how you used that add node. I tweaked my roughness map as you suggested and now it works.