How do not cook lights for a static mesh

Hello, i have a level that has a full lighted zone and then a total dark zone where u have to use a flashlight. Anyway, static meshes still get lighted when i have Ambient Occlusion enabled, even where it should be dark… How can i avoid that? Is there a way to turn off AO in game? or a way to prevent light baking for some meshes?

AO works best with small distances. You can increase the distance but it will get noisy and still wont occlude like you want. What you can do instead is set Indirect Lighting Intensity of those lights to 0 so that they light only within their attenuation radius.

I tried to follow your tip and actually the light is nice, even in dark, but behind the first corner the shadow is totally black as always… I’d like to have a realistic environment so how can i simulate diffuse lighting without AO?

Hmm, i’m a bit confused now. Do you want it to be dark or not? If you want to disable AO(ambient occlusion) in a certain area you need to use a post process volume for that area and set the AO intensity to 0. I have a feeling that you may be mistaking AO with GI(global illumination) or maybe i’m not getting it so it will be better if you can post some screenshots if you still cant get the result you seek.

ok i tried some new settings and i got this, there are all the soft shadows i want before the total dark and you were right, AO is not needed. Anyway there is a new problem, when a movable object get close to a wall with a light behind, it get full enlighted

How can i fix this last thing?
(By the way, thank you for your patience!)

No problem!

First double check to see if the cube is movable. And then go to World Settings > Lightmass Settings and decrease Volume Light Sample Placement Scale value(try 0.75 then 0.5) You can also see volume Light Samples via Show > Visualize > Vol. Lighting Samples.