How do I stop light from effecting a single asset??

It should be a pretty regular problem but there are no tutorials on how to do this.

A common problem would be a lamp shade. How do you simulate light coming through the lamp shade without having it cast the shadow of sed Lamp shade.

An example is of this is my hanging lamp.
I have a point light inside to simulate the bulb light, allowing a concentration of light to hit the floor and sealing. But the light being partially transparent it should allow light to travel though.
I then create a secondary light also inside the lamp. But the only way to allow light to travel though the lamp is to un-tick ‘cast shadows’. This also resulting in no shadows to to cast from the ceiling beams.

In short, to resolve this I would only need to stop the lamp being effected by the secondary light.
But how can I do this???


Hello Gilbert, in 4.11 you will be able to include/exclude objects to certain lights.

That said, there might be other ways, but its beyond my expertise.

Ahhhh ok thanks. Looks like ill have to wait haha. Any suggestions how i could get around this problem?

A workaround is to set the part of the lamp you dont want casting shadows as a separate material ID in your modeling program. Then in the editor > static mesh editor you can disable shadows for that material ID.