How do I remove these shadow lines?

So I’m using the 3rd person shooter template to learn materials and lighting / shadowing basics. I increased the directional light’s intensity by a little, and enabled ray tracing shadows and a few other settings. But there remains these lines in the shadowing on the surface of several meshes. I don’t see it on the top of the meshes, only on the sides, and not all of the sides or meshes either. I need to try restarting editor with Generate Mesh Distance Fields enabled. Is there a simple solution to it? any ideas or know-how of removing the shadow lines? I changed the directional light to movable, from stationary, and also changed the mesh in the pictures to movable. But static lighting and dynamic lighting are both checked for the lights, so I don’t understand what’s causing it.

Try increasing shadow bias to .6 (pic2); it might be enough.

Set the directing light as moving. Turn on RayTraced Distance Field Shadows. Set 0 to dynamic shadow distance movable light. But I do not think that this is a good solution for global coverage.

Thanks for the suggestions. I’ve tried re-opening the project, and the editor crashes before it fully loads. I’m not sure what the problem is yet. If I encounter it in a new project, I’ll try those.

I created a new project, and after changing some settings, I came across the source of it. It has something to do with the SkyLight setting “Lower Hemisphere is Solid Color” being enabled. When I changed the color of it (prior to disabling) to a light grey, it changed the lines to light grey and somewhat less visible. When I disabled it, the lines disappeared entirely.

The solution, so far, is to disable “Lower Hemisphere is Solid Color” in the SkyLight details panel under Light settings. Somehow I think it has to do with the cubemap of the SkyLight, but could be wrong. If the setting is needed to be enabled, I don’t have a fix for it.

Build your project

@Vesol You’re right about Dynamic Shadow Distance Movable, setting it to 0. It disables the CSM, which is at the crux of the shadow bands / lines problem. It’s weird that disabling “Lower Hemisphere is Solid Color” resulted in the lines disappearing. It’s as if that setting was darkening lines which were already there. So how could that be connected to the CSM? I disabled CSM in a different project where these shadow lines / bands occurred, and they were gone. But then the cast shadows disappeared, and there was only AO, from how it looked.