How do I make a custom mesh a lightsource that lights the environment and creates shadows?

If been searching all over for this but don’t seem to get a right answer that really works.

I have an architecture project that has an “S”-shaped LED stripe that should emit light as a lightsource, throw shadows and enlight the environment around it.

The mesh I importet as fbx and put a material on it that emits light. However it does not affect the other meshes around it, neither throws any shadows or is visible in reflections.

So how do I achieve this effect?

When you made the material did you put a vector3constant (constant3vecter whatever) node into the emission pin and then set the color values higher than 1. When I did that I had light coming from my mesh onto the environment. Only problem was that it seemed as though the light only appeared on the environment when the mesh was on camera. Hope this helps some.

Im not 100% sure of a fix, but i know that when it comes to lights ( point lights, directional lights etc ) you will only cast dynamic shadows and lighting if the light is set to “Moveable” rather than “Static” or “Stationary”. You could try changing this setting on your mesh. Not only the one that is casting the light, but on the assets that will be effected by the light. You could always upload that FBX in a .zip file and i could give it go and try to get it to work, or someone else might.

Hey Guys, thanks for your answers,

unfortunately it still does not work. Here’s a we transfer link to the fbx:

The idea is that the LED-Stripe should throw light on the wood panels undernath and also create shadows. So far it only seems to create a glow reflection when the camera looks right at it. Hope you can find a solution, that would be great.



This is what i get when i import that FBX.

@Leetums I tried setting the meshes to static and dynamic and the light still vanishes when the source is off camera.
Could this be a bug or it was just never intended to work how we want?

You have to untag “combine mesh” sou you will get multiple meshes. One of them should be called LED-Stripe. Thats the one that should be the light source…

I am afraid that could be the case, would be nice to have an official person responding to that issue…:frowning:

I think I figured it out a solution so I may as well share my findings. This pertains only to the lighting aspect though. I think the setting was hidden because dynamic GI is disabled by default. The reason why is beyond me. If you don’t know how to turn it on this may help. - YouTube then go to your material that will be emitting light. In the material editor look at the settings on the left under the Material drop down menu. Look for the toggle to “Use Emissive for Dynamic Area Lighting”. When that is checked and the shader is compiled the light should be visible on the environment even when the mesh with the emissive material is off camera. Hope this helps.