How do I access the Marketplace from Linux?

Using windows in linux virtual machine is also an alternative

Nope. doesn’t work. The Launcher checks for the graphics card and a virtual driver doesn’t cut it. It point blank refuses to start.

1 Like

As you can see !! it works !

My system is arch based
Using Windows 10 x64 on virtualbox
I had to make some litle tweaks with directX settings to fix the “driver issue”

It’s SLOOOOOW !!! but it works

Could you advise on what you did? Seeing how Epic is giving us zero support whatsoever.

1 Like

Hi,
I’ve made it a few month ago, I don’t remember precisely what I’ve done .

It seems to me that…

  1. I’ve installed the epic launcher on my virtualized windows 10 as usual
  2. I’ve googled the issue displayed when the launcher starts
  3. I’ve found a youtube video that explains how to solve it

Finally it was rather simple to solve.

Note that I’m sharing folders and drives between my windows 10 Guest and My Linux Host.

All my Linux projects are installed on folders that I can “see” from my windows guest (so on ntfs partitions).

The engine versions I use are installed in both OS.

As it, when I install a plugin in an engine version for Windows, I can copy its content to the SAME version of the engine but on its Linux installation. So,If the plugin is compatible with Linux it will be rebuilt and it could be loaded in the Linux version.

For downloading some project contents , I create a project with the Linux version then I add the asset to this project from my windows 10 guest , then I work with the project on Linux.

For “full project” assets, I create the project from the windows 10 version and I open or convert it from the Linux version

The same workflow can be applied when using a dual boot system (that’s the method I prefer because it also allows me to compare Windows and Linux behaviors and it’s the best way to use the Epic Launcher)

I presume that the same workflow can also be applied when running the “Lutris version” of the launcher.

I Hope it will help.

2 Likes

Thanks for the detailed response. I’ll give it a go and see where I get to.

1 Like

Unfortunately that video doesn’t apply to Virtual Machines, none of it works for fix the Launcher in a virtual machine.

I’ve found lots of post with this problem. No answers though.

1 Like

I’m sure I’ve applied The fix in the video because I still have the downloaded file (dxcpl) on my Win64 desktop

The settings is to apply to any windows 64 system that has graphic issue with the launcher, virtualized or not.
It seems to me that it was the only issue I’ve had when I wanted to run the launcher inside VirtuaBox.

And I know that Epic won’t give support in that case , that doesn’t mean that is it not possible !

What is your issue with epic launcher ?

1 Like

It refuses to run - just says the graphics card is unsupported. The youtube video fix doesn’t work. Neither do any of the fixes around WARP or opengl switches, compatibility modes, run as admin etc etc that I’ve found. Reports of it not working seem to outnumber the claimed fixes by at least 10:1.

There are poeple who have it working but there’s no coherent pattern of how. It appears that if you got it working you were just very lucky.

1 Like

Very strange indeed, because an OS running in a virtualbox will have nearly the same detected hardware to run on, depending on the virtual manager settings.

Perhaps You should try to change some settings of your virtual machine.

This is .vbox file i use for my system, perhaps it could help
Win10_x64.vbox (7.2 KB)

You could create your virtualbox machine for windows 10 and compare your .vbox file with mine to see what could explain what causes the fail

1 Like

Thanks.

As far as I can tell my settings are identical to yours, except you’re running Win10. Looks like you’re running a 5.x something version of VirtualBox as 2D Acceleration was got rid of in 6.

1 Like

no, my VB version is up to date: 6.1 (I’m on arch linux)
but the virtual machine was created months ago, with an older version, perhaps the config file kept traces of that
You said that I’m running win10, not you ? because it’s a HUGE difference no?

1 Like

Win 7 is what I’ve got in a VM. Never used Win10, never needed it. Not sure I’d even know where to pirate a copy these days. And honestly I’m not sure it’s worth the hassle given that ignoring this issue completely, I can’t even build the template games in Linux. Nothing about UE seems to work on Linux, not convinced it ever will given Epics attitude towards Linux users.

Thanks for the help and all, but UE seems to be dead end on Linux.

1 Like

I’m using UE4 on Linux without issue, even with C++ scripting.
Only the download of content could be painful, and some plugins that are not compatible with Linux

You really don’t have to find a “copy” of windows 10.
Its ISOs can be downloaded for free on microsoft website.

You can use it for free too
After 30 days , you need a key to activate windows.
If not, some customization options will be disabled but you could still use it !!!

If you have an activated windows 7 legal version, you could try to gain a win 10 key by upgrading your system. Sometime your official key would be updated too.
More info here

And legal windows 10 keys can be buy for a few dollars on the web

1 Like

I just used this Unofficial UE4 Launcher for Linux (download assets from the marketplace)
And download a few things w/o any problems!
I used a google linked account as a signin method (just in case you try something else, this method is working!)

make it sure to fork and like it on github too!

I used this tutorial to download a plugin: Download UE4 assets from the Epic Games Marketplace using Linux | Alexandra Zaharia

This is still a hassle because the Epic store has no option to add a link to your compiled version from git, you have to install a second version of Unreal Engine, stop the installation process, and then copy your version into the directory Epic Store created.

It worked but now I have another problem: This method may be fine for graphical content, but not for code plugins. The plugin in question is CesiumForUnreal, they say that it is compatible with UE5 and Linux but they don’t provide the binaries in the Marketplace download, so I had to go to their github repository and compile it myself, but it still doesn’t work because the Unreal Engine packaging script refuses to generate my package (RunUAT.sh)

So there are still some major fixes on the part of Epic required to make using UE on Linux a good experience.

Besides that I’ll try to download some graphical assets from the store, put it in my compiled version of UE5 and report back if that works.

edit: Yup it worked, tried this one: temperate Vegetation: Spruce Forest in Props - UE Marketplace
Downloaded it directly into my project with Epic Store under Lutris

1 Like

Hi there! If you’re having trouble downloading content from the marketplace website, you may need to contact customer support for help. Make sure you have a valid purchase confirmation or receipt handy, so they can verify your purchase and assist you further.

This is why marketplaces should perform a security review salesforce and make sure everything works fine. I’m sorry if my advice doesn’t help you. Perhaps someone else in the community will be able to offer some solution. I hope you’ll find answers! Cheers!

1 Like

@Johnathon Doorman (Staff)
I think it would be easier to learn Godot or Unity.

This is probably THE most offensive response I could have read.
Cursing at you would have been less obnoxious.