How do auto-generate a 2nd UV for lightmaps?

I’m new in Unreal Engine and I’m previously created game in Unity.
I have many assets from my Unity projects and I would like to transfer its to Unreal Engine. All went good except one thing: UV second channel. In Unity it generates automatically and also works fine. How can I do that in Unreal? Is possible any better way to do this than edit all my 2000 meshes in 3D software like Maya or 3ds Max?

Thanks for your reply.


If all of your meshes are UV mapped in channel 1, then you can use auto generator to use that channel to create lightmap UV’s for the second channel(Static Mesh Editor > Window > Generate Unique UVs.)

Is there a timeline for this being available in the Mac? even though I do quite like making my own its a real time save during early dev to just quickly generate one in the engine

It isnt removed, it just got more simplified. You can either enable the checkbox to generate UV’s during import, or you can go to static mesh editor > Details panel > LOD tab > enable Generate Lightmap UV’s, then hit Apply Changes button.

Has this feature been removed now?

It’s no longer under Static Mesh Editor > Window as of version 4.5

The item Enable Generate Lightmap UV’s in LOD tab is gone in 4.6.

I have it under the main section of the Mesh in the editor

Just to follow up on this topic: Generating lightmaps does nothing for the mesh to get lit. Ironically it gets lit when lightmass hasn’t yet been built.

I’d like to know how to solve this.

Interesting, can you send a screenshot of your scene, what type of lights do you have?

It is Generate Lightmap UV’s, so it creates a proper UV layout for light baking, it doesnt generate the lighting itself. Lighting wise what you see in the viewport before you build lighting is for previewing.

I prefer some of my models in the preview lighting as some of my lightmaps are overlapping causing black shadowing. Is there a way to not bake the lighting of certain models?

If I can’t find (Static Mesh Editor > Window > Generate Unique UVs.)?? I’ve not seen it and I’ve been looking for it in hours.

Just checking on 4.15 and its still there, you may have to press the show advanced button OR use the search at the top the Details tab on the right.


Then it is a bit further down


(its not a menu option)

You can make those meshes movable which tells lightmass not to bake lighting. However, unless you have dynamic lighting setup for your scene (movable or stationary lights), those models will only be lit by the indirect lighting cache and may or may not look good or realistic.

The best answer would be to unwrap your models in 3dsMax or another modeling tool to make sure the 2nd UV channel doesn’t have overlapping UVs.