How can I make SkyLight not overlap static light?

Please help. In the first image is a normal point light with static mobility, luminous in a warm color. But as soon as I enable SkyLight (image 2), its default white color overlaps the baked after build yellow reflection on the floor from the static spot light. How do I avoid this?