How can I fix this UE5 interior light bleeding issue?

I’m having an issue with light bleed in interiors of buildings that seemingly disappears as I get closer to the area and reappears when I move further away. [Edit] This issue existed prior to upgrading the project to UE5 so I don’t believe this is a UE5/Lumen issue.

Project Details:

  • Lumen is enabled
  • Moveable directional light
  • No light source within the building
  • [Edit] All roofs/walls/etc. are separate, solid meshes.
  • [Edit] Walls/roofs/etc. are 20 cm thick

What We’ve Tried:

  • Adjusting shadow bias (Setting shadow bias to 0 fixes the light bleed, but causes artifacts to appear elsewhere in the world)
  • Adjusting shadow filter sharpness
  • Adjusting dynamic shadow distance
  • Adjusting cascade shadows and contact shadows
  • [Edit] A boxed light blocker around the building has zero effect
  • [Edit] Adjusting Lumen Scene Detail and Max Trace Distance on post process settings has no effect

Below are screenshots from a distance and in close-proximity to the far corner seen in the distant image.


Any help would be greatly appreciated! Thanks in advance.

  1. Are walls are too thin?

Walls should be no thinner than 10 centimeters (cm) to avoid light leaking.
https://docs.unrealengine.com/5.0/en-US/lumen-technical-details-in-unreal-engine/#softwareraytracing

  1. Light Leaking in Large Cave-like Areas

In cave-like, or enclosed areas, if light leaking is happening, it is because Lumen limits how far rays are traced to improve performance, but missing an occluder causes light leaking.
Solution:
In the Post Process Setting, raise the Lumen Scene Detail and the Max Trace Distance.
https://docs.unrealengine.com/5.0/en-US/lumen-technical-details-in-unreal-engine/#mismatchbetweenshadowmapsandray-tracedshadows

Thanks for the suggestions!

Our walls are 20 cm thick and when we adjust the Lumen Scene Detail/Max Trace Distance on our post processor absolutely nothing happens.

Any other thoughts?