How can I fix my Scene Lighting from being too bright?

So I am working on a game project where I am trying to make a blue and cloudy looking toony sky with good lighting.

I have been playing around with this some off and on including watching youtube videos but for some reason I still cannot seem to figure out how to stop the camera from becoming blinding when looking at the ground… :frowning:

From that and the tutorials I messed around with the colors, the intensity, the light and sun direction and rotation, setting the light source but I think I am doing something wrong.

I ended up changing the color spectrum with a Scene Color Texture File to get it closer to a cartoonish look though it’s still a bit off. Not sure of a better way?

If I look one direction it looks fine but if I look another then it becomes overly bright and you can see the change occurring and switching up.

I would appreciate any help or advice to help me fix this. I would just buy one or something but I cannot afford it right now and was trying to figure it somehow. Any ideas?

Looks Fine Here or at least closer to what I Want: (Okay Lighting):

Looks Bad Here: (Bad Lighting):

Here’s my lighting settings if this helps:

Sounds like you need to adjust your auto-exposure.

See this answer to do it in the editor

Setting it to “Fixed at Log 0” will give you the true light and not brighten or darken it.

However, in my opinion the way to correctly fix this issue for a game is add a PostProcessVolume, check the “Unbound” box to make it apply to the whole scene, and then adjust your Min and Max Brightness values under the “Auto Exposure” group setting.

1 Like

Awesome, thank you so much for the help and I will go ahead and look at that more now!

I actually have a PostProcessVolume I added in there which contains a texture I created to adjust the scene colors that I was trying out.

UPDATE: Yep, that’s the problem. When I changed it to the Exposure at Log 0 it stopped doing that and is staying constant.

I’m gonna leave it this way for now because not really sure how to do it properly with the second suggestion using the post process volume. I did what you said but didn’t do anything, maybe I didn’t do it right…

Anyways, thanks, this is extremely helpful!

UPDATE: Okay, nevermind, I got the second one working! Thanks a ton!!!

That 2nd one I didn’t know that Thank You.

This helped me too. Thanks :smiley:

Thank you man, you’re the best . It was annoying that dynamic light making everything soo bright…