How can I fix a lighting leak that is going under my walls and onto my ground?

I’m setting up a tunnel that is supposed to look underground. I have connected all the walls and roofing together but lighting from the sun is leaking under the walls onto the ground, the walls are slightly clipping into the ground from the side.


does your lighting need to be baked?

Did you tried to build a lighting?

Does setting the walls so they’re not clipping into the ground fix it (meaning they’re flush with the ground instead)?

What are the skylight settings?

I tried making it flush but it didn’t fix it. I also tried making it thicker but it only helped a little bit.
Here is my Sky Light Settings.

Yes, I did.

It might work to decrease Volumetric Lightmap Detail Cell Size (in World Settings). The default is 200, so down to 150 or 100 might work, possibly 50. If trying that, try increasing memory brick data of the VLM too (right under Detail Cell Size in World Settings). No more than double or triple it though.

If those don’t work, or aren’t efficient / preferable, one other solution may be to place an extra mesh outside of the walls and floor covering where those meshes line up. If that’s not doable, try a post process volume around the corridor and change occlusion / light settings to darken it until it is sufficient.

It should already be baked

Well before I did that I changed some sun settings and got rid of exposure. You can’t really see light coming through but if you walk up against the wall flickers of bright light for some reason hit the player model.
This effect can also disappear if I move the camera a bit.


Changing the shadow cascades on the static light (The Sun) to a specific value fixed my problem. I found this answer from another thread.

A couple more things to consider:

The camera has its own built-in post process settings which could process the light differently in Play mode than in the non-PIE viewport.
Distance field shadowing might need to be tweaked so it aligns with the geometry and camera view distance(s) better.
Ambient occlusion and global illumination can produce light leaks when the settings aren’t right in the scene area. Hence, post process volumes are useful for customizing their settings for the specific area (needs to be not unbound and have a proper blend radius and blend weight if other PPVs are overlapping / nearby).

Good that it was fixed by shadow cascades…kinda weird. I’ve solved a few issues with shadow cascades that I thought were some other, seemingly more obvious issue. The fractional overlap settings for transition from one cascade to another is important because it can remove shadowing or overshadow depending on the shadow exponent.

I already had a post-process volume implemented to Get rid of the extreme exposure that is set by default. Where could I change my distance field shadowing in the post-process volume? I might want to still look into it even though I’ve fixed the initial problem.