Holes in tessellated landscape

Hello
I am trying to use the C-Media Advanced Material Pack Edition 2 material for the creation of my landscape. It is quite handy but I found some issues which I hope you will help to resolve.
The problem is that there are some holes appearing in the landscape geometry. They become more obvious when you switch to the lower quality settings. I discussed this issue with the creator of the material pack, but there is no solution so far and I would be glad to receive any help right now.
This is the thread where we discussed the issue - C-Media Advanced Material Pack Edition 2 - Marketplace - Unreal Engine Forums

Hey Kvazimodo,

Would you mind showing me your material and landscape properties?

I noticed you selected the ‘Crack Free Displacement’ but would like to see the tessellation option you are using as well as your multiplier.

Thank you,

Andrew Hurley

Hi Andrew,

Thank you for the answer.
The Crack Free Displacement didn’t give the desired effect so I turned it off later. Here are the options of the material and the landscape. I don’t think that I can show everything [like the node tree] cause the author of the material might be against that.

Regards,
Ivan

Hey Kvazimodo,

Thank you for the images as requested. Firstly, apply the material to the ‘Landscape Hole Material’ slot within the details panel. Then, crank down the ‘Displacement Modifier’ by a lot. I would even set it to 0.0 to see if it is the displacement that is causing the issue. Secondly, change the tessellation method to PN Triangles and re-check ‘Crack Free Displacement.’

Set the ‘Static Lighting LOD’ of your landscape back to the default value. Use all of these options as suggested together to hopefully hide the seams in your landscape. If you are still having trouble I will try to get the material for testing purposes internally.

Thank you,

Andrew Hurley

Hi Andrew,
Do you mean “Max Displacement” modifier that is set to 50? If so then I wouldn’t like setting it to 0 because it results in the new holes that appear right in front of the camera like on this screen

As for other options - I will try it
Thanks

Well I did everything as you told, but the problem is still there + the huge fps drop.

There is a scalar parameter value labeled ‘Displacement Multiplier’ within your landscapes material instance properties. which is set to 2000. You can keep the ‘Max Displacement’ set to 50 which sets a radius in from the player/camera in which displacement will be applied. This helps improve performance across large landscapes using tessellation.

Yes, but in this material this scalar parameter works exactly as the “Max Displacement” - it sets the radius for displacement.
There is another parameter which determines the intensity of displacement - of course the holes disappear when you put it to 0, but then there is no displacement going on at all.

You need to find the values in which you still get displacement without creating holes. If the holes disappear at 0 displacement, this means the issue is directly correlated with the values you are setting.

Ok will try to figure it out

Solved it finally :slight_smile:
The solution is in this thread - C-Media Advanced Material Pack Edition 2 - Marketplace - Unreal Engine Forums

Thank you for your help, Andrew