HLOD Not Casting Dynamic Shadows

I have set my LOD actors to cast dynamic shadows, and it works fine in editor when previewing the HLODs. However, once I run in PIE, the dynamic shadows are no longer cast, and if I highlight the actor while the game is running, the dynamic shadows checkbox is turned off again. Is there some hardcoded reason for this?

It makes the transitions between levels of LOD VERY obvious.


For anyone else who encounters this, it was apparently an engine change in 4.19 merged in from fortnite to force LOD actors to not cast dynamic shadows on load. Don’t know why this was done, but you have to mod the engine to fix it.

Hi Rujuro. I also want to enable LOD actors to cast dynamic shadows on load, but I haven’t managed to do so yet. Any chance you could help me locate the setting I need to change?



I believe our programmers had to mod the engine to enable it, let me find out what they had to change!

Looks like the change is in LODActor.cpp
void ALODActor::PostLoad()

    	StaticMeshComponent->MinDrawDistance = LODDrawDistance;
    	->Comment out this line ->   StaticMeshComponent->bCastDynamicShadow = false;	

Thanks a lot Rujuro, that fixed it.

Can’t thank you enough! Hope you have the best day :slight_smile: