Download

High Resolution Screenshot: Use Custom Depth As Mask not working

For about a year I’ve been using the “Use Custom Depth As Mask” option on the High Resolution Screenshot tool. I would select the models I want, and turn on the “Render Custom Depth” option, and then when I take a screenshot as detailed in the documentation, it would output a screenshot with a transparent background and only the selected models in the image.

Just now, I’ve been trying to do this and it no longer works. When I turn on “Use custom depth as mask”, the entire screen is green and the models are not shown.

I’ve even tried reinstalling Unreal Engine and it does not work in a fresh install.

Does anyone know what settings might be causing this to not work?

Hey there, I have the same problem. Have you found a solution yet? Or someone else?

I still haven’t found a solution yet.

Based on some research and testing, turning on “Custom Depth-Stencil Pass” in your Project Settings seems to fix this issue if it’s turned off, however, in my specific case I’m using the Ark: Survival Evolved dev kit (for modding the game), and I believe this feature is already turned on.

The High Resolution Screenshot tool doesn’t work well with screen space effects either, I’ve always used Nvidia DSR to set my monitor 1440p monitor to 4k+ and just take screen shots.

I tried using this features as well. It doesn’t work anymore, just puts out blank screenshots. Also, whenever I try to take high resolution screenshots, they come out all blurry with mip mapped textures. It seems to happen after I’ve taken multiple screenshots, as the first ones I take come out the way they were intended, with high rez textures.

Possible bug?

Hey everyone, I’m pretty sure this isn’t a bug! I had the same exact problem today but I’ve found the solution:

  1. Select the model you’d like to take a screenshot of
  2. Search through the settings using the keyword ‘depth’
  3. There should be an unchecked box called render custom depth pass - you gotta make sure you keep that checked
  4. Should be working just fine now :smiley:
  1. Make sure Opacity is >0.333333 or whatever you “Opacity Mask Clip Value” says

I have exactly the problem first described by danlev three years ago. “Use Custom Depth As Mask” used to work fine – but no longer. The solution proposed by Tetsu_jin and refined by Ramon Janousch doesn’t work for me. I’ve tried everything I can think of, even so far as doing a clean reinstall of the system (Mac OS).

I desperately need “Use Custom Depth As Mask”. Can anyone out there help???

Thanks!

After further tests it seems my problem is that I’m trying to render a very large object (mountain). So long as “Render CustomDepth Pass” is checked in Details, there’s no issue with smaller objects.

Any ideas ???

I just tested my own hypothesis and scaled the landscape to 0.01 – “Render CustomDepth Pass” works!

can anyone say solution for this

https://answers.unrealengine.com/questions/1047620/hires-screenshot-with-mask-enabled-is-having-green.html