Download

High resolution display support for editor

I use a 4k monitor and the ue4 editor font size and UI elements are borderline on usability due to small physical size with my display’s high DPI (24 inch ips at 3840x2160). Many of the applications in my pipeline (though not all yet, so ue4 is hardly alone) , offer scaling options, or can be configured to. Is there a way to raise the font size without Windows pixel doubling (unacceptable to use), and if not, any current plans to provide this type of support? Thanks for your time.

Hi ShipWorthyGames,

Go to the menu bar at the top > Window > Developer Tools > Widget Reflector

Once here you can change the “Application Scale” and change the value.

This will not just change the font size though. It scales the Slate windows that make up the editor.

1551ae1721f379beadc31f9dd60da897167f86c8.png
21dcfe70d1e11dc351e5b395f79ecaf8351c6ca0.png

Thank you!

Tim

5 Likes

Hello Tim, thanks, that’s exactly what I needed! It doesn’t persist through reloading the editor as far as I’m finding but that’s no big deal to set each time. Have a good evening.

This is great, scaling to .8 or .9 makes my 15 inch macbook much more usable. Saving this setting would be pretty neat anyway, can we configure this through some configuration file?
Any update about hdpi support on mac? lowering the scale would be much easier if retina display was correctly supported…

@ShipWorthyGames: I’m glad that works for you. I wasn’t aware it couldn’t be saved. I’ll ping on of the devs on Monday when they’re all back and see if there is a way to save that setting or if it’s not yet possible.

@Devel.bmad: Not sure on the HDPI for Mac. I’ll see if I can find an answer to this as well.

Tim

@Tim Hobson: Ok, thank you, I’m really looking forward for it.

As concern scaling: testing a bit more the functionality I found a weird behaviour on mac (I’m still at UE 4.1.1), apparently if I scale to .9 the scene outliner, the details panel and the world panel don’t get mouse click correctly. They do seem to get focus overing the mouse, but for example I’m not able to drag the scrollbar or select a different tab.
Same behaviour for some of the dialogs (e.g. saving assets): I can close the dialog, but I cannot check/uncheck items or click any button.

Turning scale back to 1.0 fixes the problem. I’m on a macbookpro and I’m using the touchpad, are you able to replicate the problem?

Yeah that is a known issue. If I remember right, there was submitted a while back as a bug. I think when I noticed it it was around .9 and lower on my screen that I could no longer click the “X” to close a window and use some of the buttons. I should have mentioned that earlier, but didn’t happen to think about it.

Tim

Hi Tim,

Are the Dev’s still working on saving the ‘Widget Reflector’ settings (e.g. scale) after restarting?
I can easily set my scale to 1.5 every time I run UE4.3, but would be better if I didn’t have to.

The technique the widget reflector uses to handle scaling the UI is not sufficient for supporting HiDPI OpenGL Rendering on OS X. We’d need to make many more changes, especially to mouse handling as you have discovered, for it to work correctly. It is something we will support eventually, but I’m not sure when.

Thx for your solution, Tim.
But there seems to be a display bug when set the application scale to above 1, I can’t select the actors accurately in viewport, there always be some deviation of the mouse click position. And the deviation increased with the scale value .
the propose is just adjust the text font size, but now it did not work well when using editor.Hope to reply soon:)

this bug(cant save widget size) still exist on version 4.6

I had this problem today and figured out a solution. Somehow when working today, I must have hit a keyboard shortcut that had turned on a Windows feature for UE4Editor.exe called “Disable display scaling on high DPI settings”. This can be found if you look at Properties on the UE4Editor.exe. Click the Compatibility tab in Properties and uncheck that. I have no idea what happened to me, but the whole editor all of a sudden scaled down. The splash screen was also scaled down. I noticed that other installs of UE4 didn’t have this checkbox set. Windows set it somehow behind my back while working.

Yup, nice feature and yet so unusable due this the selection offset bug. Would be great if you guys could fix that.

Though helpful, the Widget Reflector is still at best a temporary fix. That the editor runs on OS X is an absolute dream come true. Yet half the macs with the guts to run it (MBP’s and Mac Pro’s) are run with monitors upon which you get a sub-standard product. It’s not just cosmetic, either, since visual feedback is so central a part of the tool.

I can’t recommend enough anyone reading this to visit https://trello.com/c/D0SC1m1e and vote for this feature.

I can’t say how much important is to have a proper option like this with a laptop and 1080p, however, I don’t expect Epic to fix this, I mean, even the Windows scale option it’s pretty broken (since the beginning), so… in the meantime, when I’m working with the laptop I will be like this:

http://www.vectorizados.com/muestras/droopy.jpg

Tried to set the application scale but it broke menu dropdowns (flickers now)

Same as spyro, I have serious flickering problem when use this to address editing in 4K resolution.
On a 4K monitor, the font is too small. In addition to flickering, Widget Reflection will also affect all other UI interaction.
My preview’s widget blueprint font size scaling is wrong, where I click and drag mouse is also wrong.

First level of context menu from right click is okay, but other than that context sensitive(one with search field) will flicker like crazy when mouse move over item.

I am visually impaired and need to get all words on screen that I have to read to a size that they’re readable. At present, UE4 is completely unusuable for me without constantly using Windows Magnifier for every little thing.

When I use UI scaling in the developer options, it makes text bigger, but some menus don’t generate the scroll bars they’re supposed to. They just hide some totally necessary options off screen. So I’m forced to keep it at 1.0 scaling and zoom around with Windows Magnifier. What a mess. Fix this please!

Setting Application scale to >1.0 causes menus to flicker. Fix this please. What video driver settings need to be applied? Or a patch from you? Latest NVIDIA drivers, GTX280.

It works, but it is not permanent, I’m running UE 4.10.1. How can we save this setting? Is there a config file where we can edit the default manually? Maybe editor extension scripting or a plugin?