Download

High resolution display support for editor

I have issues in 4.10 and 4.11 where increasing the application scaling doesn’t resize the menus horizontally, and instead cuts off the menu items! The editor becomes unusable. Anyone else experience this?

Is there a bug report to follow instead of this forum posting? In addition to menu drop down issues (flickering back and forth between scaled and non-scaled, and inaccurate menu selection), I noticed scene object selection is also inaccurate. I’m not running 4k but 2560x1440, and on Windows 10 with Radeon 7850. I can test 4k as well, and I can provide a screenshot if needed.

Same here, bad flickering, meaning I can no longer use Widget Reflector.

3440x1440
‘Widget Reflector’ settings from 1.0 to 1.2

Result:
Fonts and menus = right.
Clicking on actor in 3D-view = bad.

Also the white-dummy from ue4 becomes a ghost when running. Some extrange white-shadows behind him when running over landscapes.

Working in 4k or ultraHD is poor in ue4. Very lagy when selecting and combining nodes. When you click in a node tick > left mouse > place a new node… this action takes 2-3 seconds… =slow. :frowning:

Checked out Unreal Engine today on a 4k display. Looks nice but UI-wise everything is tiny. I’d like to experiment with this for 2d games (new hobby) but going to wait until it gains support for 4k displays. And sounds like this will be a long wait sadly.
Have the devs glanced at how Blender (https://www.blender.org/) supports high resolution displays? In trying that out, it went from far too tiny to fine now, with some adjustments in its settings and preferences. As Blender is open source, a look at how they do it might help.

Since there is no plan to properly support High DPI display according to the road map, the only solution is to use the widget reflector, which is fine except these 2 problems:
(1) The menus flicker (between default scale 1.0 and your new scale setting).
(2) Scale need to be set every time when you open the unreal editor.
Please use a little development time to fix them! Thank you very much!

High DPI scaling desperately needed!

Hi friends at Epic Games,

First let me say that Unreal Engine is amazing. I’m just starting into learning it, and I really appreciate all the documentation and tutorials you’ve made available.

One issue I’ve run into is the fact that the application cannot handle high DPI monitors properly. I have a QHD monitor (2560x1440), and I need to set the Application scale inside the Widget Reflector to 1.3 to basically match the look of a 1080p screen and make the menus legible. This is great… however, there are two major issues, the first being the drop-down menus in the application do not scale up to match the new, larger text size. Meaning, “Window > Developer Tools > Widget Reflector” becomes “Window > Developer Tool > Widget Refle”, and other menus are abbreviated even worse, prohibiting a new user from understanding what they refer to without having to switch the application scale back to 1 temporarily.

Thanks very much for your time and consideration. This would be a great fix that would help new users with professional-level monitors learn the application more efficiently.

Sincerely,
Adam J

Wow, almost one year later and not even a bit of improvement? I knew this was gonna be slow but not this much… 4k displays are becoming more and more mainstream now… maybe Epic should switch to UMG xD

this feature makes all the menus flicker even on a non-4K monitor when you set the scale to < 1

I find that letting windows handle the display scaling and keeping Widget Reflector value at 1.0 works fine for the 4K UHD setup. You lose screen equity but you can tweak it in windows. The only problem with that is it applies to other programs. I just learned to live with at 250% scaling as my other apps tends to be fine also.

Flicker is never changed
[video]- YouTube
Very sadly
How I can working? Standart text size is too small on my 1920x1080 resolution monitor.

Hey, dudeses, High DPI support is actually working now, except there’s still a few bugs. You can check out the thread here: https://answers.unrealengine.com/questions/13395/is-there-a-retina-version.html

Here’s my post from Nov. 17, 2016:

Thank you AJ_Graphix.
It’s really helped me. Now my interface looks good :slight_smile:

And yes: the wires in Blueprint nodes do not respect your mouse’s position when dragging. But generally it is work, just visual it is not perfect.

You’re welcome! The High DPI feature is one that I really enjoy having now, it just makes everything look so much better. :slight_smile: Regarding the incorrect wire position when dragging: One thing I’ve found helpful is if you want to connect 2 nodes, just drag out a wire from the first node and put your mouse cursor over the input pin of the next node until the green check mark appears. Then you can release and have your wire connected correctly. :slight_smile: Unfortunately, you can’t double click a wire to add a reroute node presently, which I do miss. However, you can still add reroute nodes manually.

Had this issue with 4.14.1. The -enablehighdpi option did the trick for me. Thanks!

will the epic game launcher be optimized for retina any time soon?

This, did not work for me and I have no idea why the problem exists.

Sometimes, when I update to a new version of the UE4, the problem is there, sometimes not. There is nothing to explain why this happens other than it does.

So, without doing anything to my system other than installing 4.15, I now have a blurry and illegible UI to work with.

There is no way to fix this and there is no logical reason for it to exist in the first place.

A short list of things I have done to attempt to correct this:

  1. Created a shortcut to the editor with the " -enablehighdpi" command and *then *selected my project. No change.
  2. Altered and reset the registry editor for Windows and for Win8 DPI scaling to standard/100%. No change.
  3. Used the on-board gpu for motherboard for comparison. No change.
  4. Used DVI/D and HDMI connections for comparison. No change.
  5. Used the “no scaling” “full screen” and “aspect Ratio” setting in the nvidia control panel. No change.
  6. Used the “override the scaling mode set by applications” setting in the nvidia control panel. No change.
  7. Used the “perform scaling on display” and “perform scaling on GPU” settings in the nvidia control panel. No change.
  8. Re-re-re-installed the nvidia gpu drivers. No-no-no change.
  9. Re-installed Dell Ultrasharp monitor driver(s) and associated colour profiles. No change.
  10. Re-installed x-rite (Dell official) colour calibration software. No change.
  11. Confirmed in DXDIAG that my rig is running WDDM 2.1 and DX12.1, and that backwards compatibility is functional. No change.

Used (1) with ALL combinations of (2), (3), (4), (5), (6), (7) totalling more than 24 different combinations.

If there is another combination I need to try, please let me know - I am running out of hair to pull out of my rapidly disappearing head :slight_smile:

Still a problem…

Well… I see this is gonna be a loooong road… I’m still interested tho… Opening Unreal in a 4k mobile pro is such an adventure time…

C:\Unreal Engine\Epic Games\4.14\Engine\Binaries\Win64\UE4Editor.exe" -enablehighdpi
Doesnt work for me. Same UI. Win7 @ 3440x1440
The best I got was to change the widget reflector to 1.15.

Question1.
¿Is there a way to change fonts type in the UE4 UI??
UE4 uses some tiny arial type, I suggest to hardcode UE to show the fonts in bold. This would gain a lot, more readable fonts.

For Maya there was a similar problem that was resolvered adding -plastique at executable end …and editing the strings.

And here is another way, in this case for Photoshop and only valid for WIN8. I have Win7 and cannot try it.