Hiding object to camera, but keep that object visible to sceneCapture2d


I’m trying to make something similar as shown in the link below : (Batman VR)

Working on VR game, I want to keep character head invisible to camera, but want to show that in mirror (sceneCapture2d)
What I’ve done so far is, made a dummy sphere as character head, set it to ‘invisible in game’, I’m getting shadow of head (enabling cast shadow from hidden objects) by this trick, without showing head in camera.

Problem: “I want to show character head in mirror”, for this purpose I’m using sceneCapture2d as mirror.
with above trick, character head (sphere) is not showing in mirror too.

(problem snapshot)

Any sort of help will be appereciated.



Hello, did you have any luck figuring out a solution to this issue? I’m having the same problem.

Hi @playhouse,

Yes, I’ve figured out a solution. All i had to do is tick “Owner no see” checkbox on player.
this will allow object to spawn in world and act normally but it wont directly render on camera. but indirectly, (using mirror / reflection) it will work.

let me know.