Download

Help bad lightning when built

Hello , First of all I am very new to this engine, but I have some problem , when I build the level the lightning on the walls I have gets strange, why this is happening and what is the way to fix it?

It might be a smoothing issue

Hi!

I’m guessing by the sceenshot that the whole building is 1 mesh…
In Unreal you set lighting information in pixels… so if you set like 64 res lightmap (or even 4096) you’ll get an extremely low res lighting result…
If you want better results you’ll need to break up your mesh into smaller pieces + you’ll need to go higher with your lightmap resolution…

How about posting some of the lighting settings (World Settings Lightmass, directional light details panel, skylight details at least)? Is there any dynamic lighting, or is it all static?

Yes was one big piece of mesh so I split and increased lightmap texture size from 64 to 4096 , seemed to work well but then I added more pieces and I got this …

What can it be?

Seems like a system memory issue while baking or rendering lightmaps. How much RAM do you have? Also 4096 is very high for lightmap resolution, try within 128 - 512. If those don’t work you need to better you UV’s and split up your meshes for optimization.

I have used the one autogenerated from game but lower res gived be some artefacts, I will tr to reduce to 512 the largest ones, I have 32 gb ram , how can I do allocate more?

Could be just a glitch: try to open swarm agent, clean cache and then validate and try to build again! Sometimes it happens…

  • 1 high res lightmap takes (a lot) more time to calculate than many smaller one covering the same area!! /let’s say 1 x 4096 takes a lot longer than 4 x 1024!!/

I already split my walls of the building from a big single set with a 4096 to 4 pieces, should I split even more?
Also I have tried adding lights and they create all sort of problems , if I reduce texture sizes it tells me there are overallping uvmaps problems in lightning texture :((( .

Depends what the plan is with the project… if draw calls doesn’t matter and you need high quality lighting: break up the whole builind per wall! Then you’re in full control where you want to set better quality lighting!
Texture size you mean lightmap resolution? …well if it’s overlapping, it’s overlapping no matter the resolution! Lightmap uvs’ should never overlap! Every face/polygon should have their own separate uv island and not a shared one!
…if you have areas that are invisible (if you’re baking an interior, you don’t need the outter faces) you can exclude them from the lightmap uv!

We have noticed some strangeness with lighting behaviour since the introduction of raytrace so before going nuts trying to fix the problem we are going to wait a bit to see if Epic will fix it in due course. Something we have noticed both sky light and directional lights cast shadows which kind of conflicts as both are GL based lighting elements and by turning off cast shadows on the sky light produces a different and more predictable result yet benefits for the general and indirect lighting.

I have again reduced the walls, I get no more uvmapping uv and no other errors , but the process stops when arrives to 35% and it then says that ligtning needs to be rebuilt , but everytime I do it stops at 35% …
Its like an industrial building, its a ex revit exported model so is a realistic model not for game and not built mdularly but is made of thousands of blocks primitives that I had to reqork for uvmaps in 3dsmax and rescale b4 exporting …
I am getting mad now !

I just updated with the new version and now after building when arrived approximatively at 20% it crashed and then a message said video drivers was closed and reset …
I am really not understanding what I am doing wrong, would be possible from someone to review myscene and tell me what is the problem eventually?
Thankyou everyone.

in case what part of the file I shoudl pack to upload?

Here is what appears inthe swarm agent after it stops .

Done some other experiments and I tried to split in rooms, I had then the usual uvmap issues and so I increased the resolution , this solves in part the problem but I get still artefacts like those

[Screenshot - bbba0e850c2c7752f1658e34c9af375b - Gyazo

The problem is that rightnow I am using 512 res lightmaps, when I read others are using as low as 64 or 128 , if I rise even more I suppose I will get again the memory problems as I have to add still a thousand other walls like those pieces… what u sugest?](Screenshot - bbba0e850c2c7752f1658e34c9af375b - Gyazo)

Here I am uploading a fbx , its just a portion of the huge building need to do , but I want to understand what are the issues, I am having even with custom made plain lightmap uv and on angles I get weird shadowings…

And here is the unreal project level , I just skipped on materials that are too many and heavy folder, I just used anyway a plaster material on walls, glass on windows and plastic on deck , marble on floor.

Any help would be great thankyou!

btw remodeling walls is not an options because there are thousands of them and I could just rescale textures .

Hi!

I’d say that it’s either a driver or memory problem… or something is wrong with the mesh that’s being calculated when Unreal/lightmass crashes!
If you have a huge building /downloading your files now…/ you’ll need to break it up into smaller areas as streaming levels! If not the end user will run into memory/performance issues + the bigger problem is that you won’t be able to pack a level larger than 2 Gb!!

On the screenshot it looks like bad uv mapping to me + maybe your compression is still on?

…so for a reason in the Unreal project file the meshes/level won’t show up!
I imported the fbx!
Many of your meshes /like your floor!! :S/ is made out of planes! Unreal needs to have thickness to calculate proper lighting!
Give some thickness to those areas and you’ll get better results!
Also your lightmaps are not ideal! I haven’t checked all of them!! What I’ve seen is /the floor doesn’t have a lightmap uv! :S/ that most of your islands are really small there is a huge gap between them! You should make the islands as big as possible /this is your lighting map in pixels!/ but still some gap in between!
…the rest of your settings I couldn’t check! :S Maybe if you could reupload the scene…

Ok thankyou so , basically you say I need to split the macro pieces into smaller clusters or smaller pieces?
Trying that …