Heavy handed occulsion shadows

Hey all, I’m getting this weird issue with my meshes where the I’m getting very noticeable ambient occulsion shadows and I have no idea why this is happening.


Has anyone experienced this, or know what’s causing the issue?

Thanks in advance for any and all help!

Hi Huskey3737,

This actually looks like a low lightmap resolution rather than an issue caused by the ambient occlusion. Can you try adjusting the lightmap resolution to a higher value like 128 or 256? If this is a mesh that you made a larger value may be needed, but that largely depends on the UV layout that is setup and how much each UV island is taking up.

Give that a shot and try rebuilding the lighting. Let me know if that works for you.


Hi Tim,

Thanks for the response, turns out I was the light maps I ended upping the size and redoing some of the lightmaps to add more padding to avoid issues. Another question though, would you happen to know why this is happening?


I’m around 95% sure that it’s not coming from a light source, so I have no idea why I’m getting this issue.

Thanks for you help thus far. :slight_smile:

Can you post a screenshot of your UV Channel 1 layout. You can do this from the static mesh editor. Use the UV toolbar button and the drop down for UV Channel 1.

Also, what is the current lightmap resolution that you’re using? It currently still looks like a low lightmap resolution issue. The quality of a light build can largely depend on how this lightmap was setup, and how much space each uv island is taking up in the space. If this is a large mesh with lots of uv islands the lightmap cannot generate enough quality the islands at a lower resolution.

Here’s the lightmap that I currently have.

I also forgot to mention that as I was doing my research, I found that by altering the some of the lightmass settings it would remove an issue I was having with the tiling assets having different shadow values. Modular Asset Lighting Problem - Rendering - Epic Developer Community Forums
Currently I have the Static Lighting Level Scale is 0.1, Num Indirect Lighting Bounces is 50, Indirect Lighting Quality is 1.0, Indirect Lighting Smoothness is 3.

I feel like I’m doing something right, but then again I don’t have much experience with lightmass in ue4. Thank you so much for helping me out with this!

What is the lightmap resolution set to? The image above would still indicate a lower lightmap resolution with the amount of bleed that is happening. Also, I’d rotate the larger piece on the right to face vertically so that it’s not laid diagonally. This can cause artifacts as well for areas where you need smooth shadows on flat wall.

If you’ve not read this already I’d recommend reading over the Lightmapping Documentation.

I wouldn’t necessarily recommend jumping to using the Static Lighting Level Scale of 0.1. This setting isn’t really needed in 99% of setups and is really only something I’d recommend with ArchViz work, unless you’re targeting a specific style of game that requires a different units scale that is not centimeters.