Hair Opacity not accurate

Sorry if this is a basic question, I’m new and learning.
I’m running into an issue, where I can see parts of the mesh I’m not supposed to. Even when I set the opacity to one, as long as my blend mode is translucent, I get this issue.
Searching the web, I found similar questions from 10 years ago, saying it was an unreal limitation. But since it was such a long time ago, I’m hoping there’s a way to fix it now.


With Opacity at 1:


When set to opaque, it doesn’t have that issue, but I cant have it be opaque because I have an opacity mask I must use.

It seems like the Opaque shading mode should match the Translucent mode if the alpha is set to 1, but it doesnt.

This is a translucency sorting issue, there is no good way to resolve it.

Your best option is to use a masked material with dithered opacity, this is what Epic (and pretty much everyone else) does with all of their hair materials.

If you’re feeling adventurous you could try the new order independent transparency feature (checkbox in the project settings in 5.1). I expect it will be very expensive.