Green Screen Bug

Hello, i’ve been getting this green light in my level for a while, but i can’t tell which is the problem. I tried every ‘solution’ from other topics but none seems to work. Is it a bug or a specific light setting. I’ve got my graphic card up to date and 15 GB of ram to use within the Engine… Also, i am using a different skybox and it doesn’t get affected in the ‘Reflections’ View - so i guess that’s a problem?

It could be a post process setting on your camera, to test replace your current player camera with new one or make sure there are no yellow indicators in your post process settings. to confirm its not your graphics card I would just make a brand new project.

This is my log when i build it. Also i have checked the post process and still no difference. i have rebuild it with and without any source of light…

And if i had to make a black project, I just migrate all files from the old one to the new one right?

Hi,

I’d like to assist you with your issue so lets try to isolate this issue a bit. Try creating a new default level and let me know if it is still green. If the new level you created isn’t green we can safely guess that the issue lies in your scene. Creating a new project will be fine too but, I think making a new level will get some smaller questions out of the way sooner.

Thank you for submitting this bug and I hope that I can help you figure this out!

Ed Burgess

Hello,

I’ve created a default level in this project and the bug doesn’t show up. I’ve also created a new project with the same template and everything is normal. In the current project (the one with the bug) i have a total of 4 maps, this being the fourth one. However, the green light doesn’t show up in the other maps.
Thank you for assisting me and i hope we will get this solved as soon as possible. Let me know if you need any other detail.

Okay, so now we know that the issue lies with something in your scene and not the editor. I have some questions for you.

First, does the green tint show up all the time or only when you Play your level in the Editor.

Second, if the green tint is always there then I would guess that you have a postprocess in your level set to unbound. Just to be safe you can remove or disable all postprocesses in the scene. Does that fix the green tint?

The green light shows up only when i play the level. I have deleted all post processes and rebuilt the light but unfortunately the bug persists.

Next, you should check the actor that is being spawned into that level (usually player character). Just like what NanoVoxel was saying earlier, go into that Actor Blueprint and check the Follow Camera component. You should see Post processs settings in the details panel and check the scene color dropdown. Just make sure everything is disabled.

If that doesn’t work you can try deleting the file located in LauncherBinary>EpicGames>4.11>Engine>DerivedDataCache

I can also say that I am fairly certain this issue has nothing to do with building the lighting. The reason you are getting errors is because you have overlapping UVs on your static meshes. I hope that helps.

Ed Burgess

Thank you for your time Ed, but none of these worked. I will be making a new project and i will migrate everything there… Hopefully it will work somehow… Anyway, would it be possible that i have two player characters in the level, and this is what turnes on the bug? At the begining of the level, a new character is spawned next to me and i can posses it. I also checked it’s camera and all postprocess settings were off.

Hi Xanadron,

I would hold off on migrating your project since the issue may exist in your scene. Lets try to narrow down the possible issue even further.

I have a few tests for you (check to see if the green tint goes away after every step):

  1. Set all of your lights to movable and build lighting.

  2. Eject from your player when you Play in Editor.

  3. If issue is still there when you Play in Editor, start going through your world outliner and delete one by one things that could possibly influence the color or lighting of your scene.(make a copy of your level first in case you mess something up)

Example: Delete atmospheric fog> Play in editor > Still green > Stop playing and hit Control-z to bring back atmospheric fog > delete directional light > etc… rinse and repeat.

My guess is that you have an actor in your scene that is has it’s visibility turned off and when you play it starts rendering again. So if you want to save time check and see if anything in your level is hidden before you start deleting stuff.

Hi Ed,

As i told you, i have already tried these before asking the question, in the way you explained to me. I was fortunate to have a backup for the project. I can’t say i’m happy because the bug is still unresolved. I still can’t figure out what was all about. I’ll make a backup everyday from now…

Xanadron,

I’d like to investigate this issue further. Could you provide a sample project with your existing bug? Preferably on google drive. If you are worried about privacy you can send me a private message on the Unreal Engine Forums:
My S/N is EdBurgess.

Hello Ed,

I would be glad to send you a sample, but the problem is that i have already replaced it with an old map. I still have the bugged map but whenever i try to load it, it will load the old one, no matter if they are named differently (apperently UE still sees the map’s name ‘ThirdPersonExampleMap’ even though i renamed it as ‘bugged’ for organisation purposes) Also, i haven’t found you on the forum. Is it any other way for us to get in touch?

Hi Xanadron,

I’ve sent you a private message over the forum, I’m also going to mark this ticket as resolved since it seems that this isn’t an issue with the engine. If you are able to reproduce this issue on a blank project and feel that this is actually a bug feel free to reopen this ticket by posting a comment.

Thank you

Ed Burgess