Download

Grass rendering distance?

Hello, I started learning the Open world tools recently and I’ve found an issue which I don’t know how to solve.
I followed this tutorial https://docs.unrealengine.com/latest/INT/Engine/OpenWorldTools/Grass/QuickStart/index.html for creating grass step by step.

So I’m using Landscape tools / Paint for creating the grass and other elements like rocks and bushes. But sadly the rendering distance is extremely low. It only shows the ground texture even in the nearest mountains.

72d57510ba50f061d1502604c215d6e286045299.jpeg

I checked and I’m using Epic settings already. I tested with different settings but the results are always the same.
If you see in the screenshot it only shows the area where the latest brush has painted. If you move a little the next “circle” appears and so on.

Any solutions or ideas?

Take a look at this thread: https://forums.unrealengine.com/showthread.php?72172-Increasing-grass-culling-distance-beyond-foliage-tool-limit-Grass-stops-rendering-too-short&highlight=grass+draw+distance -> probably it will solve your problem :slight_smile:

Stupid question but… where do I put that command?
I can only enter the console while ingame, do I have to paste it there?

*Edit

This is the max I can have. With 0.000001 ammount. Is it normal? In kite demo you can see a lot more grass in the distance…

72478b0d47c61dec8f3f0fc96d348364aab23ca3.jpeg

Compared with this one specially from the tutorials
26d5babf458fa0c1651f28ab7960b83bbc9bc1a3.jpeg

The settings for this are found in the Landscape Grass Type.

3b0b3e438dfd1b41bb59a41bfc2b55135a23361a.png

Start and End Cull Distance.

Sorry to necro this thread, but I have exactly the same issue. And turning the cull distance to 0 (to disable it) makes it so that no grass shows up at all. Any ideas?

Set your end cull distance to a very high number. (10k<)

I tried setting it to the max, (256k or something like that, and it still didn’t show up properly)

I’ve done some research, since I had the same issue with the trees, and using “Foliage.MinimumScreenSize 0.0001” command solved that (combined with disabling LOD3 in the trees by setting size to 0)

This is my problem right now, that black spot should have a high concentration of grass, but nothing shows up until you get close enough. it also shows the settings I use for my grass.

My LOD seems to be fine, as shown by this picture:

Imgur