Graphics card crashed or D3D removed crash constantly

I keep getting this error and it’s becoming hard to accomplish any sort of designing as it crashes consistently.

I have done several google searches and many of the them state it’s the graphics card being overworked, that something could be overboosting the graphics card, or that I should just update unreal.

However, I cannot find any boost on and I have a 3080ti with 12 gigs so I shouldn’t be crashing several times in session, right??

Here’s what I’ve checked

  • I’ve checked my nvidia experience. I can’t seem to find any boosters on, any of the online guides show settings like battery boost or game boost but they are in older versions and I haven’t seen them being used anywhere (or even the options)

  • I have checked my MSI center app and have it on balanced

  • I had virus scanning off at first. Since that had no effect I turned it back on.

  • I have RTX 3080 ti with 12 vram and the pc has 64gb ram

  • nvidia driver is latest studio driver.

One thing I notice is that around 8gb the program switches to using shared ram vs dedicated and when it crashes it’s usually somewhere around 8.3 combined use.

Please help!

I have also been experiencing this constantly with UE 5.0.0, at seemingly random times. Attempting to get more information by using the -d3ddebug option causes other crashes immediately upon interacting with the viewport, and I can’t tell if it’s related. I have reinstalled my NVidia drivers, tried switching to their Studio drivers, tried increasing my TdrDelay in my registry, and a variety of other shenanigans in an attempt to get around the issue. At one point I disabled TDR entirely, but that eventually made my whole system hang and I had to force a shutdown.

The usual crash log ends with this error:

[2022.04.19-17.04.56:940][324]LogD3D12RHI: Error: pResource->Map(Subresource, pReadRange, reinterpret_cast<void**>(&pData)) failed
at D:\build++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12RHIPrivate.h:1387
with error DXGI_ERROR_DEVICE_REMOVED with Reason: DXGI_ERROR_DEVICE_REMOVED

interestingly, I don’t have a drive D:\ on this computer, nor have I ever run anything related to unreal from a drive D:\

The crash resulting from -d3ddebug has about a million of this line or similar lines:

LogD3D12RHI: Warning: ID3D12CommandList::DrawInstanced: Vertex Buffer at the input vertex slot 0 is not big enough for what the Draw*() call expects to traverse. This is OK, as reading off the end of the Buffer is defined to return 0. However the developer probably did not intend to make use of this behavior.

followed by the error:

LogD3D12RHI: Error: ID3D12Resource2::: CORRUPTION: An ID3D12Resource object (0x000001D60773B750:‘NumCulledLightsGrid’) is referenced by GPU operations in-flight on Command Queue (0x000001D5F1166880:‘3D Queue 0’). It is not safe to final-release objects that may have GPU operations pending. This can result in application instability.

I have updated to UE 5.0.1 today, and things have gone smoothIy for an hour or so. I am hoping that the issue has been resolved, but only time will tell.

Same issue here, also 5.0. I’ll try updating to 5.0.1 and see if there is any improvement.

In general, when you have this kind of instability, and other people don’t, it’s almost always a hardware problem.

I had a bunch of crashes with both a GTX 1080 and a RTX 3090.
The crashes went away when I moved the card to another slot on my motherboard.
The card was in the preferred “slot 1” but I moved it to the second x16 “slot 3” and it was fine.
In fact, I think it would have been fine in an x8 slot, too, if needed x8 vs x16 isn’t that big a difference in practice.

After making sure that you have a strong enough power supply, and solidly seated CPU/cooler, good RAM, latest BIOS, and all the rest, try moving the card to another slot, and see if that helps.
If that also doesn’t help, try the card in another machine (find a friend to test with) and try another kind of card (e g, ATI) in your machine.
The problem will either follow the card, or follow the machine, or it will mysteriously go away, meaning it’s a machine+card compatibility problem, which are the worst to debug.

And, yes, it feels as if hardware should be a “solved problem,” and most bugs are software bugs, but in these particular cases, I’ve found it’s actually usually hardware.

There are a variety of topics and posts related to this one on the forums, and three people besides you have posted on this one, which was made 10 hours ago. I can’t help but note that other people are having this problem.

On the note of hardware, my computer is absolutely brand new. Does this mean that nothing is faulty? Of course not. However, UE5 is the only program this issue crops up in for me. I have also run Alienware’s diagnostics in ‘thorough’ mode from the BIOS, and everything (all memory tests, processor stress tests, graphics tests, etc) came back successful. Does this mean that nothing is faulty? Again, no, but it seems more like there’s something obscure not quite accounted for in the newly released UE5, particularly with the changes between DirectX 11 and 12.

EDIT: So apparently it’s a known issue, according to someone on this discussion:

UE5 gpu crashed or d3d device removed - Unreal Engine / Getting Started - Unreal Engine Forums

So… That’s cool. I guess I’ll just hope that things were fixed a little in 5.0.1?

1 Like

So, I updated to 5.0.1 but I still have the same issue. I had it in Unity as well, so it might be hardware for me.

I know the feeling. I chased something like this for years, and it only happened in UE5. I use plenty of other 3D software, for CAD and content, and none of it had the problem. New power supply, new BIOS, new cooling, … Yet, moving the card to another slot, finally solved the problem.

DXGI_ERROR_DEVICE_REMOVED is not something that Unreal (or any application software) even has control over – it’s from the kernel. When this event happens, it’s either a driver bug, a kernel bug, or a hardware problem. I’m mentioning this to suggest where to look for a solution that will actually work, based on my experience.

That being said – I haven’t tried UE5 on top of the debug D3D runtime. If that immediately crashes, that would be a pretty good indication of a software problem, which may perhaps provoke whatever the underlying problem is. Maybe something like this could help shed some light?
win32/directx-12-programming-environment-set-up.md at docs · MicrosoftDocs/win32 · GitHub.

I have this same issue.
Forced into using DX12 (because otherwise nanite doesn’t seem to work)
Never had this problem with the Early access versions and I wasn’t forced to use DX12 for Nanite there either.

Exactly. My computer is also new and I only have problems in unreal. That leads me to believe it’s either a driver issue with Nvidia and unreal or unreal.

Seems like it’s definitely the driver. This is the discord message on the Unreal Slackers discord that the other discussion referenced:
image

Those links don’t go anywhere anymore. Someone was asking on the 17th about whether there were any updates on the issue and no one seemed to have anything more to say on it yet.

I can confirm the issue seems to be driver related. (Using latest NVIDIA studio drivers)

I’m using an RTX 3090 on Windows 11 and UE5 was crashing regularly.

I included the commits listed on Unreal Slackers with the latest 5.0.1 build of Unreal and the device removed crashes have stopped.

The Unreal Slackers links are still valid for me.

Try to configure your NVidia control panel to not apply any antialiasing overrides and let the application pick its own AA method.

Not sure if your comment was directed to me, but my antialiasing overrides were already set to application controlled.

The only fix that works here is to add the commits listed on Unreal Slackers.

Those links don’t go anywhere anymore, so actually there just isn’t a fix at all.

I just wanted to chime in to say we have been struggling with this issue as well, and noticed that the problem is a lot worse on Windows 11 vs Windows 10.
So we changed over to Windows 10 and are having far less problems.
Something to consider if it is an option for you.

yeah, got the same problem but only after i upgraded to windows 11.
in win 10, UE5 was running smooth and no crashes at all for me
(using a gtx 3080)

Same situation here, running UE5.0.1 on a Windows 11 (10.0.22000 Build) machine, Ryzen 5 5500X CPU with 32GB DDR4 RAM @ 3200 and a RTX 3080 GPU with 10GB VRAM.

Also no Boosters in NVIDIA Experience enabled, tried to turn off the Antivirus, set Virtual Texturing on, and not even slightly reaching 10GB VRAM on my GPU. Studio Driver DCH 512.59 installed:

 at D:\build\++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12RHIPrivate.h:1387 
 with error DXGI_ERROR_DEVICE_REMOVED with Reason: DXGI_ERROR_DEVICE_HUNG

[2022.04.27-14.24.17:037][800]LogD3D12RHI: Display: D3D12 CreatePlacedResource failed with params:
	Heap Type: 1
	Heap Flags: 192
	Resource Dimension: 1
	Resource Width: 2560
	Resource Height: 1
	HeightFormat: 0
	Resource Flags: 0
[2022.04.27-14.24.17:037][800]LogD3D12RHI: Error: hr failed 
 at D:\build\++UE5\Sync\Engine\Source\Runtime\D3D12RHI\Private\D3D12Resources.cpp:629 
 with error DXGI_ERROR_DEVICE_REMOVED with Reason: DXGI_ERROR_DEVICE_HUNG

[2022.04.27-14.24.17:037][800]LogD3D12RHI: Error: [GPUBreadCrumb]	Copy Queue 0 - No Data
[2022.04.27-14.24.17:050][800]LogD3D12RHI: Error: DRED: No breadcrumb head found.
[2022.04.27-14.24.17:050][800]LogD3D12RHI: Error: DRED: No PageFault data.
[2022.04.27-14.24.17:050][800]LogD3D12RHI: Error: Memory Info from frame ID 4797:
[2022.04.27-14.24.17:050][800]LogD3D12RHI: Error: 	Budget:	9310.00 MB
[2022.04.27-14.24.17:050][800]LogD3D12RHI: Error: 	Used:	3124.20 MB

This problem is now listed as an open issue in the official release notes for the latest NVIDIA drivers.

As it has been acknowledged as an issue, hopefully it will be fixed at the driver level soon.

2 Likes

So a new “unreal” ready studio driver was supposedly just released. Is this that? Or is this that update?