Download

Grainy textures when moving problem

Hello, something really weird is bothering me a lot in UE4, and I don’t know why I hadn’t noticed this before. Basically when I move around, looking at a texture that is very detailed (high res) and probably grainy (like some grunge textures for dirty walls), there will be a lot of noise on the texture despite AA being turned on. It looks terrible because when I move around the noise also moves, so the texture looks like it’s a bunch of static like the ones from those old TVs until I stop completely. I thought it was the normal map being too sharp and noisy, but it happens even if there’s just a diffuse map on the material.

The texture looks great in, say, CrazyBump, but inside UE4 it just looks way worse because of that.

Is there any way to fix this “issue”?

Can you post a screengrab of your results of UE4 and texture? It will be more easy to debug your problem. Also just check that in your texture you have mip gen settings to “FromTextureGroup”

Best Regards

Hmm, I checked if that was the issue but apparently it wasn’t… But I found the issue. It was just that the viewport AA quality wasn’t at the best setting for some reason. In Simulate mode the issue disappeared.

Temporal AA is very frame rate dependent so with noisy content you can see some very different results at the lower editor frame rate compared to running the game standalone or even with PIE in a new window with the editor minimized.

Im actually having this issue as well, and its combined with the fact that the editor world freezes unless I move around in the editor (particles and everything, materials, all, just freeze).

AA Is the culprit indeed here.
I made a comparison a while ago when I had similar problems.
FXAA seems to fix it for some materials, while creating artefacts on others (solid color).

https://forums.unrealengine.com/showthread.php?124959-Temporal-AA-artefacts

Here are the links to the test videos:

https://www.youtube.com/watch?v=bSuMBa9DjrA
https://www.youtube.com/watch?v=vXQsE7rJyqw
https://www.youtube.com/watch?v=V_KlyC35YG0

Hope that helps :slight_smile:

Als try disabling Motion blur, it can also be the culprit.

So, I had this EXACT issue (at least I think so), and the answer was turning on “Realtime” in the viewport, as temporal AA is indeed very framerate dependent. Do this by hitting the dropdown arrow on the top left of the 3D section of the viewport (ya know, where it says lit and you can visualize things, to the right of that). There, click realtime, it should be the top option. Make sure it’s checked, because it spontaneously turned itself off for me at one point when I changed the shadermodel to a different one.

This fixed my problem thank you