Google Sketchup Overlapping UVs

Ive been working with modeling for a while now and have started to develop a game. Ive created all the models but whenever I inport them there is bleeding because of the overlapping UVs. The only UV set that is overlapping is the one generated from google sketchup and its the texture UV. Really need help it is very irritating. Thanks in advance

Heres what it looks like


The SketchUp have some problem with export UV channel.

This is tool for work with UV in SketchUp.

Also you can use 3d programs such as Blender, MAYA, 3DS MAX and use they for unwrapping UV.

Keep in mind - your static mesh need contain two UVs. Secondary UV used for Lightmap. If your model have only one UV, you need activate auto generate secondary UV in import dialog.

Thanks but it didn’t work. still looks bad. The uv map from sketchup looks like this. This is the first map

Open your mesh in Mesh Editor in UE4 and check next:

  1. Your mesh must contain secondary UV. If not, delete mesh from content browser and import it again with Generate Lightmap UVs parameter.

  2. Change Lightmap Resolution. Some time you need just input different value and back old.

  3. Check Light Map Coordinate Index parameter. It always must be 1.