'Generate UV's failed' error

Hello. I am getting. Generate UVs failed. Couldn’t convert to a D3DXMesh. HELP. The model has been made in sketchup and used in unity pro. And then i imported from unity to unreal engine 4 and when rebuilding lightning i got a error about UVs found internet that to fix it i need to generate UVs but i am getting error. If someone can please fix this model for me. Or tell me how to fix it. I am begginer in UNREAL ENGINE 4. Model link: CLICK ME MEDIAFIRE

Hello Herobrine112211,

So the only files we are compatible with for static meshes are .FBX and .OBJ file types. If you are using SketchUp to export your mesh, there is an option to export it as a .FBX file. Keep in mind that if you are scaling in centimeter in SketchUp then it should work fine because it transfers over to the engine properly.

Here is some documentation on how to work with .FBX files once you have them exported:

Hope this resolves your issue.

Thanks,

Andrew Hurley

I did use .FBX file with texture files. Sketchup model was exported from tutorial video from youtube. It worked in unity without problem. Soo what should i do? i dont know how to resize objects in sketchup i only know how to make models there.

The mesh itself, not the texture file, needs to be either a .OBJ or a .FBX file. For not do not worry about the scaling. Just see if the static mesh imports as intended.

Everything is ok. Tested by exporting using blender. I don’t know. Could you please fix it? it have meshes. Please.

What version of the engine are you working in? I tested this issue in 4.5.1, but this could be version specific.

One of my colleagues pointed out that two of your texture image file are not a power of two. i.e. 256x163

I use 4.4.0. I will upgrade to 4.5.1 if i need to.

If you have an active account try updating your version to either 4.4.3 which was the last hotfix pushed for the 4.4 version of the engine, or you can go ahead and move to 4.5.1 and see if either of these solve your issue.

I was able to import your mesh and your textures with no trouble in my version of the engine, so this might be the cause.

Nope. I updated and still the same problem. I really need this model. Same problem with other people sketchup made models. And i noticed in 4.5.1 there is no generate uvs button in windows tab anymore where can i find it?.

The location of the “Generate UV’s” can be found here.

Still getting the same problem: wrapping uvs. Here is the object in game:

And here is the object uvs:

I posted a new comment. Check it.

Yes, notice how your objects UV’s are overlapping? You need to unwrap your model so none of those faces are overlapping one another.

Or you can “Generate UVs” and set the" Lightmap Coordinate Index" to 1.

How do i unwrap them in unreal engine 4 and it dosen’t let me set lightmap coordinate index to 1.

Refer to the image I posted to see exactly where in the details panel to set the “Coordinate Index” as well as “Generate UVs.”

Yes. I set generate uvs. Then save. And then i want to set that coordinate index to 1. BUT IT DOSEN’T LET ME. It automaticly reset the number to 0 in coordinate index.

So I was able to reproduce what you are talking about, but it seems you have way too many individual components on your command center. You need to break things apart that are meant to be represented as their own mesh. For example your satelite, the computer screen, and the machine components inside of your house need to be on their own seperate 0 to 1 UV space.

Because everything is being pushed on one lightmap, it cannot effectively generate an effecient UV for your static mesh so it continues to default to 0.
Try dividing your mesh up by type, like the house structure, the satelite, the computer monitor, and the internal parts to get the correct results.

Here is some helpful documentation on how to optimize your models so when importing them into the engine, they are clean.

Static Mesh Creation Pipeline:

Lightmaps and Unwrapping:
https://docs.unrealengine.com/latest/INT/Engine/Content/Types/StaticMeshes/LightmapUnwrapping/index.html

Thanks,

Andrew Hurley

Please. I want to make a game and my project is sucesfull on kickstarter. I need to make this game next year. How do i fix it if it dosent let me to change from 0 to 1. or what to use to create models but NOT blender. I dont know how to use it. Please.What would you recommend me to use or how to fix it.

I have a car that i would like to import but it have the same problem and i cant cut the car in a half what would i do then?

You need to split the car up into different categories when Unwrapping your model, but you can still import them by combining the mesh. For example your wheels should probably have their own UV’s.