Gear VR - floor material showing black on start of game

When ever I launch my game in Gear, the floor, walls, and roof all appear as black or transparent. My level at the moment is just a square room that surrounds the character on all sides, I don’t have a skybox and my scene is lit with a point light inside the room. I also have other objects in the scene such as the players gun which Im holding in a first person perspective and some blueprints that after I look a certain amount of time I can teleport to their location.

For some reason when I launch the game in gear (only in gear this happens) the walls dont render and I’m left floating in space. I can still see my gun, arms, and teleport blueprints but the walls are all black. It’s only until I teleport to one of my teleportation blueprints that the the walls appear but once I fire my gun which spawns a projectile and does a line trace the walls disappear again. I also occasionally see the walls render for maybe a frame or two in one of the eyes before going black. Has anyone else ran into this problem before?

Hello Lasyavez,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue in a clean project?
  3. Could you provide screen shots of the issue and any blueprints involved with this issue?
  4. Could you provide the exact device being used with the Gear VR?
  5. Could you provide the exact version of the OS that is being run on the device?

Ok Rudy I was able to reproduce the black screen with a clean project.

  • I set up a default level
  • copy the floor 5x and then place them around all four sides and one to top off the box you just built
  • Add lightmassImportanceVolume and a point light (static) inside your new box level
  • I deleted the skysphere bp as well as the directional light that comes with default.
  • I had my own first person bp but I just ran a test with the default firstperson BP and my left eye was not rendering the textures but my right eye was rendering.

That’s it for my set up here are some picks of the level (you can put spheres in level to see that some stuff does render while the walls dont.

I am using the snapdragon Note 4 with Android 5.1.1

.

Hi Lasyavez,

I’m helping Rudy out with this one since I have a Note 4 to test on with my Gear VR. I was not able to reproduce the issue using the steps you’ve laid out above.

Would you be able to upload a simple test project with that can reproduce this that I can take a look at? There may be a setting somewhere that is not set correctly or something that just needs to be enabled/disabled.

Let me know.

Tim

I’ve not heard back from you in the last few days. I’m going to mark this as “resolved” for the time being, but if you are able to provide a simple project that reproduces or any follow-up steps that can assist in reproducing the issue I can test on my end and see if I see the same.

You only need to post back here to re-open the issue for investigation.

Thank you!

Tim

Hi Lasyavez,

I’ve not heard back from you in the last few days. For the moment I’m going to close this issue since I cannot reproduce. If you’ve got additional information that can reproduce this or a simple project I could use that reproduces this you can simply post back here to re-open the ticket.

Thank you!

Tim

Hey Tim here is a link to my project. https://drive.google.com/folderview?id=0B3VaQcJHcyVZOXZaZEk1YVdHVGc&usp=sharing

I am using a modified vr controller from the community VR template but I dont see why that would cause the issue. I hope this helps in solving the problem. I also noticed that I don’t get this problem when I’m in the first person example map.

I tried loading this up on the GearVR and I’m seeing the room as your image has it above, and this is the way it looks in the editor as well.

I’m not sure if I should not be seeing the floor at all, if there should be materials already applied or I I should apply a material that causes the issue to occur.

If you have a screenshot of your device that shows what the issue is could be helpful as well.

Thank you!

When you look around or move around the material on the walls don’t go black? How could I screenshot whats happening on my device?

Not sure how to screenshot that in that case. I was under the assumption that it wasn’t showing at all.

Even still, when I use it on my GearVR I’m not seeing any issue with the room. I have full head control movement and all 6 walls are visible without any of the default materials going black.

Does this happen in any project that you create or only this one project?

It was happening on other projects I was creating that I was outputting to the Gear. I haven’t encountered that problem since I’ve moved over to an Oculus project.

Since I’m not able to reproduce this, I’m going to mark this as “resolved” for the moment. If it comes up again you have any steps to fully reproduce the problem I can test on my end again and see what I find.

Thanks!