FPS stuck at 75 - help?


I seem to be having some sort of GPU bottleneck and I’m running out of things to check. It doesn’t seem to want to go over 75FPS on this project (occasionally it goes up to 80). Actually, I think the GPU is sleeping more than it is working. I’m trying to figure out the best way to approach this. The game thread runs at 4-5 Ms 99% of the time and the draw thread as you can see below is less than 1. This is an issue because when I run it on Oculus the frame rate cuts in half.

Vsync is definitely off, So is frame smoothing. I also tried with it set to 120 min and max.

I set the game to wireframe for these shots to minimize whatever is being rendered. Am I correct in guessing that the huge white gap in the bar of the profile window is the thread sleeping?

Any suggestions would be helpful. This machine has 16Gigs of ram, an I7 at 3.8Ghz, and a GTX 780. It shouldn’t be slow.

This is called vsync. You are probably capped at your monitor refresh rate.

Sorry, I somehow missed this till now.
In the screenshots above, you can see r.vsync = 0. yet its still on apparently. whats up with that? is there another vsync setting I should be aware of?