Download

FPS issues but performance has been in mind since the beginning.

So today i noticed a massive fps drop. In editor i get about 120 fps when i hit play in new window, i get around 30 fps in high resolution and about 80 fps small window resolution.

I am not sure where the drop is coming from.

my textures are all power of two, 1024 x 1024 150 ppi.

My meshes are all low poly with high res normal bakes as normal maps.
I have multiple LOD for every mesh. I am using world composition with 3 seperate LOD’s.
Dynamic lighting set up.(which might be the issue but not sure where or how to fix or see if it really the problem)

How do i investigate where the fps drop is coming from?

I only have 3 characters with blueprints in level and max about 4 event ticks.

When my character is at a high point overlooking the whole level (which is only one landscape square resolution 505 x 505 64 quadrants) im getting about 15 fp >+(.thought i was doing everything right for performance, but 15fps is terrible and I havent even really started filling up the level with meshes and actors =O

Any idea where to start? Thanks!

Hi, first would be the console command “stat unit”, to see whether you’re CPU or GPU bound (from the sound if it seems you’re GPU bound, but just to make sure).

If you’re GPU bound, then I would go with “stat gpu” next, if you’re bound by the game thread, then I would go with “stat game” (and then maybe the profiler if you can’t directly see where the problem is).
[HR][/HR]
So could you show an image of the result of “stat unit”, and then if you’re GPU bound from “stat gpu”?

With UE4’s built in profiler tools

Thanks ill giev this a look!

Sweet Ill

Sweet ill watch this now! Thanks!

QUOTE=chrudimer;n1803331]Hi, first would be the console command “stat unit”, to see whether you’re CPU or GPU bound (from the sound if it seems you’re GPU bound, but just to make sure).

If you’re GPU bound, then I would go with “stat gpu” next, if you’re bound by the game thread, then I would go with “stat game” (and then maybe the profiler if you can’t directly see where the problem is). [HR][/HR]
So could you show an image of the result of “stat unit”, and then if you’re GPU bound from “stat gpu”?
[/QUOTE]

When I entered stat GPU and stat UNIT

Seems your GPU is underpowered for volumetric fog. You can try tweaking the cvars (type “r.VolumetricFog” into the command terminal to see all of them) but honestly you’re so far over budget that you should probably just consider turning Volumetric fog off completely. I can’t even see it in your screenshot so I’m not sure what it is contributing to the scene.

That should also reduce the cost of SSAO, as I’ve noticed volumetric fog drives up the cost of SSAO.

Edit: I’d also suggest replacing your Atmospheric Fog actor with the new SkyAtmosphere actor instead, it’s cheaper on my machine anyway.

That’s kinda all the low hanging fruit. If you’re not using distance fields then you should turn them off, but I’m guessing since you have a terrain that you are probably using them for distant shadows. You could try switching to 8bit distance fields (which is what fortnite uses if I recall correctly) but I’m not sure that will have any impact on the frame time, or if it is purely a memory optimization.

I gotta say that video you sent is really hgelping me a ton!!! Just being able to analyze whats happening during run time is gold!

Thanks! I completely got rid of my exponential fog, and another fog i had ( yea they werent doing anything for my scene (i might have added earlier in development and forgot about them… I disabled Atmosphere fog from my directional light. I added the sky atmoshphere.

I believe i am using distance fields for the dynamic light ( i think. i could be wrong.) I just disabled and lets see what happens.

Where do i set the 8 bit distance fields? is that the compress mesh distance fields option?

Thank you so much for the info my friend!

It looks like im nearing 50 FPS. Nice!

its getting better but i want to get about 60 fps average. im going to proceed with the videos you sent.

I noticed i somehow had 2 direction main lights. so i deleted one and now in easy rendering areas, Im getting about 55-60.