Forward shading and dynamic shadows

I’m new to the forward shading/rendering stuff in unreal and I can’t get a light to cast dynamic shadows (at least not a new light).
I noticed that the given light source (directional light) in the standard (no starter content) scene casts dynamic shadows when forward shading is active. But only as long as I don’t rotate/scale it by the gizmos or don’t change specific options in the light (some infuence the shadows some don’t).

On PlayInEditor and on packed project the shadows are casted dynamicly.
But If I change some of the specific options it won’t cast any dynamic shadows anymore in PIE and packed. Also I can see how the shadows change in the viewport to a sligtly more blured shadow.
Duplicating the light also destroys the dynamic shadow. Deleting the duplicate lets the original light take over and cast dynamic shadows.


I attached a the [test project][2]. If the original light doesn’t cast dynamic shadows you can load the map to restore.

I didn’t try light baking yet, but I think this won’t be a problem (hopefully :x).

The documentaion states that dynamic shadows are supported for stationary lights on forward shading.

I read this post:

Where can I find these 4 channels to add a stationary or movable light?

I read this post:

and I can’t get any light to work. :frowning:

First being that Dynamic only
Directional Lights are not yet
supported for Forward Rendering. You
still need to have the Static Shadow
Casting enabled. This may be added in
a future release, but I’m not sure
it’s going to be in 4.15 as it’s
currently not in my latest build.

Im guessing this might have something to do with it :slight_smile:

I didn’t build the lighting… (I don’t have any stationary object in the scene, so I didn’t thought of that)
thx MonsOlympus for the response. I read over these lines several times, but only now I came to the idea to build the lighting.

k, thx, bye :wink: