Force No Precompute Not Working

Force No Precompute is not working. At all. See below image. I NEED my light to be stationary but without that preview watermark in it. I also set it to not show that watermark in the viewport but it still shows up. How do I stop it from showing up? I just want dynamic shadows from my stationary lights. I don’t want to set the light to be moveable.

How do I get rid of that preview watermark? If I have to change the engine code to do it just tell me where that watermark is and I’ll change the source if I have to. I need that preview watermark gone while playing the game.

After setting “Force No Precomputed Lighting” to true you need to build lighting. I know this seems counter-intuitive but it should work for you.

I believe you can also disable the “preview” showing in shadows somewhere in project settings.

I am curious, though, why you are so adamant about setting your lights to static when you don’t want any static lighting. Seems like the easiest way to fix this is to simply set your lights to movable.

Rebuilding the lighting doesn’t work. It still shows the “Preview” watermark when you click play.

Has this been resolved yet??

Been wondering the same thing for the longest time

the PREVIEW you’re seeing there is because the light is set to STATIONARY. set the light to be MOVABLE so that it’s not using lightmap uvs for it’s shadow map.

you’re saying your light must be stationary, but that’s impossible without precomputed lighting because it literally bakes your lights shadows into their shadow lightmap…and there is no lightmaps with precomputed lighting turned off.

the way stationary lights work as far as i know is that when you’re very close to the shadow, it’ll be drawn dynamically, and as you walk away from it, it’ll be swapped for a baked lightmap shadow to cut render costs. so obviously this is impossible with precomputed lighting turned off, thus you really have to set the light to be movable so that the shadow isn’t using lightmaps.