Foliage tool not blocking navmesh?

When I drop some static meshes on a navmesh, the navmesh updates and edits out those spots where the static meshes are. However, when I place the same meshes using the foliage tool, the navmesh does not update, and any AI proceeds to ignore the object causing the AI to get blocked/stuck. I have BlockAll enabled in the foliage instance properties, and I even tried the “Collision with World” checkbox in foliage instance. Is there something else that I am missing that enables foliage meshes to interact with the navmesh? This occurs on both landscape and BSP.
Thanks

Hi jig,

Thank you for the feedback. You are right, this setup should give you the results you are looking for. I was easily able to reproduce the issue and I have submitted it to the developers to look into.

Thanks, TJ

If you press P to show the navigation paths, then go to Edit/Project Settings/Navigation Mesh and enable Draw Path Colliding Geometry, what do you see?

If I do this, the good news is that I see the collision meshes from the foliage. The bad news is that they’re in the wrong places. :slight_smile:

I’d be interested to know if you see the same thing. If so, I think I’ve probably hit the same bug as you, and I can just get on with other things while I wait for it to be fixed. (I also wanted to let Epic know about the meshes appearing in the wrong places, because it may give a clue about the cause of the bug.)

Hi PeteX,

I tried your setup and I don’t see the collision meshes for the foliage. Could you send a screenshot of what you’re seeing?

Hello,

I thought I’d try this with a new project, to make sure the issue wasn’t a quirk of the larger setup I’d built. This is what I did:

  1. Create new empty project. Project opens with just the two chairs and the table.

  2. Add a large box brush to serve as the floor. I used 10,000x10,000x200.

  3. Add a NavmeshBoundsVolume and position it over the floor. Mine is 8000x8000x200.

  4. Build the paths and press P. You see that the whole area is navigable except for a small space where the chairs and the table stand.

  5. Edit the SM_Bush sample and add a collision mesh. I used 10DOP-Z but probably anything would do.

  6. Add SM_Bush to the foliage system. On the Instance Settings page, change the collision preset to BlockAll. Change the density to 10 so you don’t get cluttered up with hundreds of bushes.

  7. Paint some bushes on the floor we created at (1).

  8. Rebuild the paths. There are now gaps in the navigation mesh as you would expect, but they are not aligned with the bushes.

  9. Enable Draw Path Colliding Geometry. You will see that collision geometry is shown but in the wrong places.

Here is a screenshot of the paths at the end of these steps:

https://docs.google.com/file/d/0B_p65X45P-3QZHVQUm5DOTlNWGM/edit?pli=1

(I’m fairly new to all this, so I’m sorry if I’ve just misunderstood how this is supposed to work.)

Best,
Pete

PeteX,

Thanks for the thorough repro steps. I was able to recreate what your seeing and I’ve added this issue to my original bug report.

Thanks, TJ

Looks like this is fixed in 4.4. Thanks for getting this issue addressed.

doesn’t seem to work, but I’m new to Unreal, maybe I’m missing something. I have a sphere I imported from Maya, added a sphere collision and saved the scene, if I add it as a normal object it has collisions, if I paint it as foliage with collision Presets to Block All it collides with the character, but the navmesh doesn’t update. I tried all custom navigable options, I rebuilt all, I rebuilt paths only… nothing. The navmesh doesn’t take foliage into consideration. I’m using the latest version, 4.10