Foliage isnt darker in the shadows of landscape or static mesh

The right side on the pic is lightened by a dircet light, the left side is in the shadow of the landscape.

You can see that the foliage grass is not darker in the shadows of the landscape or the cylinder (static mesh)
only the shadows of the trees (foliage) makes the grass darker.

In the foliage-setting I have adjust that the foliage grass doesn’t cast shadows, the tree, the landscape and the direct lighting have the option “cast shadows” on

Is there a way to make the foliage shadowed by landscape- and staticmesh-shadows?

Can someone tell me if this is a bug, false adjustment or this isn’t implemented in the engine?

I’m using 4.2.1

Just a quick question, are you using static lights? I am curious if this is an issue with just needing to rebuild lighting.

Also if you place one of the meshes you are using for foliage in the same spaces (not as foliage type, just as a staticmesh) does it light properly?

Yes the landscape use static shadows. If I put the grass as a static mesh and not as a foliage on the landscape (with “Cast shadows”=off) the grass are darker in the shadows of the landscape (but if I light them with a spot light [which I attached on the player as a lamp], the static meshes get only lighten on the side which faces the sun, the other side keep dark even if I light them with my lamp)

I found this thread, it seems I’m not the first person with this problem

Hi wARmAcH1n3 -

You said you were using a “direct” light did you mean directional light and if so what is it set to (Static, Stationary, or Movable)? Try Stationary and see if the shadows return. Also make sure you are building your lights.

Thank You

Eric Ketchum

I am sorry but I do not see a problem with that picture? could perhaps demonstrate by putting the foliage in the shadow of a mountain to better demonstrate? Then I could see the problem and help :slight_smile:

yeah I meant directional light, it is setted as Stationary. If I set it as movable it works, but I don’t want to have the sun as totaly dynamic light because higher performance.

in the half of the picture at the bottom you can see the border between shadow and no shadow (with brown color) (the sun is on low position and cast long shadows). the shadow of the cylinder doesn’t shadow the grass too.

This is a missing feature, translucency does not receive shadowing from a Stationary light in 4.2. In 4.3 (not out yet) there’s approximate shadowing for translucency from Stationary lights, but it might not be accurate enough for that case.

If you can afford to use Cascading Shadow Maps on the directional light, that will shadow the grass properly. To enable CSM, set the DynamicShadowDistanceStationaryLight to 2k or so.

Ok I will wait hopefuly for 4.3, I want make the grass with low performance cost, thx for the info.

Hi ,
with Cascading Shadow Maps it works! The foliage is darker in shadows. Thx!

I have the same issue (screen attached)

I was able to fix it by clicking “Dynamic Indirect Lighting” inside Directional light. I turned ON and boom, it fixed the problem but later I turned it OFF and grass was still fixed :. So this switcher did something but I have no idea what happened. Is something broken?
Anyone could give me clue what is happening? Should I keep “Dynamic Indirect Lighting” on or off? What if recalculation of the lightmaps will cause the problem again?

“This is a missing feature, translucency does not receive shadowing from a Stationary light”.

Ok, but Will it be repaired? When?