Download

Flying Foliage

Hi everyone,
I made an Island with terrain editor and add generation foliage in the terrain material. The foliage should only be on the mossy landscape layer:
e5569e97ba47c726a12df427c27bc2a66af77a18.jpeg

It works perfect, except for two locations where there’s flying foliage, like a column of foliage, with vertical and horizontal grass…

127c63175561696f81c7c515e7ac6fca91206325.jpeg


15d54f5e33517dd1d9b5f597add0a88e289155c0.jpeg

Any ideas where the problem come from?

I’ve seen a somewhat similar situation with foliage where it wouldn’t always line up with the landscape during sharp inclines/declines in the geometry unless the landscape sample quality was pretty high. Does it only do this in drop-off areas like that, or is it happening in any flat, smooth areas?

You’re right, it’s happening near big"wall" I don’t have this problem on flat and smooth area. I will try to fix that :slight_smile:

Well forget what I just said, it also happended above big flat area…
5fbd09a92fd5b6ee32148b0fcfcfdb34b9299ad7.jpeg

I tried to reshape the area but the evil column of random rotation foliage is still there :frowning:

Yes it’s also happening on flatter and smoother area:

5fbd09a92fd5b6ee32148b0fcfcfdb34b9299ad7.jpeg

I have only see that bug in origo.

That still looks like it’s pretty close to an area where there’s a sudden incline in the landscape geometry. Here’s a visual of what kind of happens (or at least happened to me)

Depending on the resolution of your landscape, the grass mapping may be approximated along fewer points, resulting in these average lines being drawn, where the foliage lines up to the red line at a harsher angle than the landscape geometry itself, represented by the green line. Try resampling your landscape to a higher resolution and see if it still occurs in those areas.

Simply use a LandscapeLayerSample node. Give it the name of the layer you want the stuff to appear on. Plug it to your grass node.

I did it. That didn’t resolve the probleme but it’s more elegant to do it this way :slight_smile:

I did the resampling but I have now a big issue. Everything turn black when the camera approach…
[video]https://youtu.be/8m-S5pR50w8[/video]

OK, another problem, when I’m using the retopologize tool in sculpting landscape mode, the bug is expanding:
dabbd1e96d3de8d24c5309b24cb29e4d4cd21ecd.jpeg

Posted about it a while back After using visibility tool, foliage stuck in air - UE4 AnswerHub Let me know if my fix helps to fix the issue for you too.

I tried to follow your instructions but didn’t find the merge option you’re talking about.
It seem the problem happend every where I used the retopo tool while I sculpted and painted the landscape :confused:

Ok try this, remove the landscape material, then make a hole covering the affected area, then close the hole, then re-add the material, it might be related to the material and the landscape hole.

That works great! NowI will try to repeat the operation without loosing the topography and the painting! Thank you very much!

The problem may resurface, when you create a landscape hole again.

Thanks to everyone I succed inremoving those strange unwanted flying foliages:
Select components of the Landscape affected by flying foliage
Copy (Ctrl+ C)
Remove those component
Add New component
Paste (Ctrl + V)
[video]- YouTube

I had a similar issue and what was causing it, was some strange Topologies on the landscape. Obs: Be careful when using the Retopologize tool on the Landscape Sculpt tool!
Even if u try to fix it with the tool it can get worst. Our Friend Kald is showing the best solution! XD

Foliage is actually painted ALSO ON HIDDEN OBJECTS (and can be painted via checkbox on top of other foliage). Try deleting any hidden objects from scene before you paint and uncheck “foliage” in paint tool.