Failed to kick off Swarm on certain levels

Certain levels wont let my build light, with “Swarmagent failed to kick off” as the reason.

[Interface:OpenChannel] Error: System.IO.IOException: Processen kan inte komma åt filen C:\Program Files (x86)\Epic Games\4.12\Engine\Binaries\DotNET\SwarmCache\AgentStagingArea\v1.9193097137F5E6FCC8E1F5D97588CEDE9E48F1C1.mtrlgz eftersom den används i en annan process.
   vid System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   vid System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
   vid System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   vid NSwarm.FSwarmInterface.OpenChannel(String ChannelName, EChannelFlags ChannelFlags)

I Think the error occured after me trying to setup my swarmcoordinator, but since i reinstalled everything that had to do with the swarmagent and UE4 i dont know how it could be a problem still (the settings are back to default)

My Colleague is able to build light in the same project and i can build light on certain maps.
I reinstalled all UE4 engines, removed the Swarmagent etc. Cleared Appdata, Removed all saved/Intermediate.
There are is only one instance of UE4 active aswell as one instance of Swarmagent (when i press build light).
I reseted the level specific lightmapsettings, and im getting the same result.

I tried installing on another computer, and im getting the same error.

I can’t even build with an exact copy of the project my colleague is using (we are using perforce).

Summary: Can’t build light on certain levels. Swarm Failed to kick off with error that a swarmcachefile is used by another process. I can build some levels… bu colleague can build all.

I tried:

  • removing all Epic related folders and uninstalling the engine. (including Swarmagent cache location)
  • Cleared my Appdata
  • Copied my colleagues project
  • reverted the entire project to a state 2 weeks ago when i know i could build.
    *Swarm agent to standalone/notstandalone
  • tried building without networkconnection
  • checked through all folders for possible not added assets (using perforce)
  • Tried different engine version
  • tried on another PC with freshly installed UE4

Next on the list is to reinstall windows… but it feels like i shouldn’t have to.