Failed to cook dedicated server

I develop a multi-player game.
I will hosting the game server on a dedicated server, so I need the dedicated and standalone server

I follow this tutorial, but, at step 8, I can’t cook content…
The message log is : “game module target is not found”
Any idea?
Thanks

Vana29,

In order to better assist you, I will need the full output logs uploaded as a .txt file.

Thank you!

Sorry, there is the log link text

Vana,

It looks as though your issue can be resolved by reviewing this post. Please let me know if you’re still having trouble after going through the steps.

Thanks! :slight_smile:

I think I have not package the project.
So, after launch the uproject with the build engine, I launch the package build but I have some errors.
link text

Your error is as follows: MainFrameActions: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: Couldn’t find target rules file for target ‘-Project=C:\Users\Ludovic\Documents\Unreal Projects\test\test.uproject’ in rules assembly ‘UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null’.

Please make sure you’ve built your project correctly in Visual Studio for the target platform. Check through the steps in this AnswerHub post and see if any of them help get you further along in packaging. Please also try to create a new project that’s similar to the one you’re working with and try to package it.

Please upload the new logs once you’ve attempted these.

Thanks!

I delete my project, recreate a new c++ project, build it with VS

I delete the build and intermediate/build folder but I have always the same error … I can’t package[link text][2]

(I create my project with my build of unreal engine )

We are on the same project, and we have the same error

I will update VS to update 3 and retry

Have you both updated? Visual Studio update 3 is going to more than likely cause trouble for you with 4.12.4.

Is this happening on a newly created project? If you can provide me with exact, full repro steps, I will gladly try to reproduce what you all are doing here.

Thanks!

there is a fix for Update 3 :

Hi everyone,

I just wanted to pop in here real quick to let you know that we do not yet officially support Update 3 for Visual >Studio. Our goal is to have support for new VS updates by the time they are officially released (Release Candidate >versions are not official final release versions). Sometimes we are able to get that support into the Engine early, but >as of right now it is not in place.

I brought this up with the individual who will be responsible for making sure support for Update 3 is added to the >Engine. He has not done any testing on this yet, but he believes it should be possible to correct this issue by >opening the WindowsPlatformCompilerSetup.h file in source code (this won’t correct it for the binary version of the >Engine, unfortunately), and remove 4599 from the table of warnings at the top. Then add #pragma warning(disable : >4599) below the list. It is possible that this may not work since the warning is coming from command line arguments >instead of source, but it’s the first thing he is going to try when he starts working on support for Update 3. He also >said that he does not believe this edit will have any adverse affect on your game code generation, but stressed >again that he has not done any testing yet.

For now we recommend sticking with Visual Studio 2015 Update 2.

Tim

I have not test yet with it.

For step, I just open the last Unreal version (4.12.4) with the launcher( or from source, it’s the same error), create a c++ project. I try to open the uproject file, but it says the dll is misiing and rebuild from source. I open the sln project, build with VS and reopen the uproject. I try to package and I have the error message

Thanks for sharing the workaround. :slight_smile:

So I created a C++ project on the binary version of the engine. I closed Visual Studio and the project and proceeded to open the .uproject. It loaded without any dll errors.

Please update me once you have tested with the update.

Thanks!

I up to 4.12.5 and VS update 3, and try to create a c++ project
There still the same error message …

The project could not be compiled. Would you like to open it in Visual Studio?

Running D:/Programmes/Epic Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe test Development Win64 ->project=“C:/Users/Ludovic/Documents/Unreal Projects/test/test.uproject” -editorrecompile -progress -noubtmakefiles >-NoHotReloadFromIDE
ERROR: Couldn’t find target rules file for target ‘-project=C:/Users/Ludovic/Documents/Unreal >Projects/test/test.uproject’ in rules assembly ‘UE4Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null’.
Location: D:\Programmes\Epic Games\4.12\Engine\Intermediate\Build\BuildRules\UE4Rules.dll
Target rules found:
UE4Editor - D:\Programmes\Epic Games\4.12\Engine\Source\UE4Editor.Target.cs
UE4Game - D:\Programmes\Epic Games\4.12\Engine\Source\UE4Game.Target.cs
UnrealHeaderTool - D:\Programmes\Epic >Games\4.12\Engine\Source\Programs\UnrealHeaderTool\UnrealHeaderTool.Target.cs

I try this fix : link text
but when I create a project, I have a new error message …

An error occurred while trying to generate project files.

Running D:/Programmes/Epic Games/4.12/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -progress
UnrealBuildTool Exception: ERROR: A game project path was not specified, which is required when generating >project files using an installed build or passing -game on the command line

I don’t understand, I add the path …

Vana29,

We believe that you’re missing your Project.Target.cs file. In order to get this file back, you’ll have to recreate it yourself.

the files already exist in folder

97705-target.png

source :

// Copyright 1998-2016 Epic Games, Inc. All Rights Reserved.

using UnrealBuildTool;
using System.Collections.Generic;

public class testTarget : TargetRules
{
	public testTarget(TargetInfo Target)
	{
		Type = TargetType.Game;
	}

	//
	// TargetRules interface.
	//

	public override void SetupBinaries(
		TargetInfo Target,
		ref List<UEBuildBinaryConfiguration> OutBuildBinaryConfigurations,
		ref List<string> OutExtraModuleNames
		)
	{
		OutExtraModuleNames.Add("test");
	}
}

Thank you for verifying that you have that file. Do you have your Server.Target.cs file? If not, that will also throw this error out.

Also, in the Intermediate folder, there is a “PCH.ProjectName.h.cpp” file. There should be a path to your projects header file. Check if the path is correct.

Update me when you can, thanks!

I have not this files, so I create it and add some code with link text

I retry to cook, but fail …(same error)

I found the “PCH.ProjectName.cpp”; The path of my project header file is ok.